This project is read-only.

Install question from an IIS/.net noob

Topics: ASP.NET 2.0
May 31, 2007 at 8:15 PM
Hello, I'll preface this by saying I don't have a ton of experience with .net or IIS, and I think I've followed install instructions the best I can... My issue is as follows.

- I put all files in a directory called /blog
- I give App_Data write access
- I choose /blog folder in IIS, right click>properties, create application name "blog"
- I then hit up the /blog directory in firefox and get a configuration error

Based on what I can tell from the error, it is reading web.config in my root directoy, not the /blog directory. Which of course does not work as intended.

Strangely enough, if /blog IS NOT set to be an application, it does seem to read the correct web.config, but of course, produces errors.

Any info or feedback would be greatly appreciated!

PS, if I'm missing something blatantly obvious, feel free to throw a fish in my direction :)
Jun 5, 2007 at 9:02 PM
Interesting issue. It sounds like a web.config conflict.

The last time I ran across this was with a test site made with Microsoft ASP.NET Atlas (before it became ASP.NET AJAX). The site that used Atlas in the root folder on a test server. A while later I needed to test something different, and went back to this test server and made a folder/application. A folder was added off the root folder, but had errors because the new app didn't have Atlas.

I'd recommend testing to see if you have a web.config conflict by going to your root folder, and renaming your web.config to something else. (If you can do all this on a test server that is best, but if it is just a personal site, it isn't the end of the world to go down for a minute.) Then, browse out to your /blog folder. Does it work now? If so, something in the root web.config is conflicting. If not, do you get the same error? Anyway, don't forget to put the root's web.config back.

Jun 5, 2007 at 10:02 PM
Thanks for the reply.

I put the blogengine web.config in the root DIR and blogengine appears to work correctly. So it certainly is an issue with the web.config in the root dir.

At least you've experienced something similar and now I have something to google for :)