Create an API for Google Docs?

Jun 29, 2007 at 3:39 AM
I think it would be a great idea to get in contact with Google and see how we can go about getting listed on their Google Docs API. This would allow posting to our blogs directly from Google Docs.

Any thoughts?
Jul 8, 2007 at 3:48 PM
Hello,
Could you be more specific and point me to a link that shows the existing possibilities of the Google Docs API?
Thank you :)
Jul 8, 2007 at 7:51 PM
I'd love to, but it doesn't exist.

I noticed when I used my Google Docs account that you could post directly to a blog, it allows you to specify one of several. I sent an email their way asking for information on how we can get BlogEngine.Net listed, but haven't heard back. I think it basically will take a web service that takes a user name, password, post, and title then they tie into it. Not much work needed to make it happen, just need to get them to list us.
Jul 8, 2007 at 10:17 PM
Ok, thank you for the update.
Coordinator
Jul 8, 2007 at 10:52 PM
I saw this post and figured it should be possible to set it up with the MetaWeblog API. However, after I made a document and tried to publish it to BlogEngine, I got an error. It did pass my connection test, but I just couldn't post my test doc.

I then tried to publish to a test wordpress blog (which is an approved blog) and got an error as well. (The test worked fine for Wordpress as well.)

Have you specifically tried to set it up to post to a custom blog and put in your blog url with /metaweblog.axd on the end? I figure I must be missing something as I've never used Google Docs before. I wonder where the post title comes from and how you might set categories.
Jul 8, 2007 at 11:14 PM
Razor,
I've not tested at all. You want to post the settings you put in and I'd be glad to give it a test whirl myself. I would say categories won't work....
Coordinator
Jul 9, 2007 at 11:56 AM
The setting I tried where:

  • Provider: My own custom server
  • API: Metaweblog API
  • Url: http://www.nyveldt.com/blog/metaweblog.axd
  • UserName: MyBlogEngineLoginName
  • Password: My BlogEnginePassword
  • BlogName: Blank (It will appear after you try to post)
  • Include Doc Title: Checked. (If I leave blank, I get an error saying I need to include the title.)

Jul 9, 2007 at 1:39 PM
This worked for me!! Sweet!
Aug 31, 2007 at 12:52 PM
Done evrything in the above, but I don't have metaweblog.axd in that location....didn't come in my downloaded .zip from this site.

Is it missing, discontinued?

Where can I get metaweblog.axd file?

Using BlogEngine.NET 1.1 / Office 2007

Thanks
Aug 31, 2007 at 9:15 PM
I think I am being a little dopey here. What are you all doing with the Google Docs? Are you posting to it through metaweblog? Are you trying to tie the body of the post to the google doc? Just curious. I have some other ideas for some Google stuff. Let me know.
Aug 31, 2007 at 9:40 PM
Paul, you won't see the file in the location it is handled through BE.

RC, you can setup Google Docs to post to your blog after you type it up in Google Docs. Just a neat little feature....
Aug 31, 2007 at 10:42 PM
Copy that. I was thinking you were trying to go from BE.N to Google.


ckincincy wrote:
Paul, you won't see the file in the location it is handled through BE.

RC, you can setup Google Docs to post to your blog after you type it up in Google Docs. Just a neat little feature....