Culture IETF Name zh-CN\_vti_cnf is not a recognized IETF name

Topics: ASP.NET 2.0, Business Logic Layer
Jul 25, 2007 at 12:33 AM
I just upgraded to version 1.1. This is one of the problems I have been having both locally and on the server. When I go into admin and click on "Setting", I get the following:

[ArgumentException: Culture IETF Name zh-CN\_vti_cnf is not a recognized IETF name.
Parameter name: name]
System.Globalization.CultureInfo.GetCultureInfoByIetfLanguageTag(String name) +2288892
Coordinator
Jul 25, 2007 at 10:58 AM
I'm very sorry to hear that. Do you know what is needed to fix the issue?
Jul 26, 2007 at 3:05 AM

madskristensen wrote:
I'm very sorry to hear that. Do you know what is needed to fix the issue?


Could it be a missing patch? It seems to be only happening on the server now:

[ArgumentException: Culture IETF Name zh-CN\_vti_cnf is not a recognized IETF name.
Parameter name: name]
System.Globalization.CultureInfo.GetCultureInfoByIetfLanguageTag(String name) +2288892
adminPagesconfiguration.BindCultures() +150
adminPagesconfiguration.Page_Load(Object sender, EventArgs e) +31
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +34
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1061
Coordinator
Jul 26, 2007 at 9:20 AM
the vticnf is something that frontpage extensions create. Try to open the App_GlobalResources folder and see if there is a folder in there. there must not be one.
Jul 28, 2007 at 12:42 AM
Edited Jul 28, 2007 at 12:43 AM
In my local AppGlobalResources folder, there are "labels" managed resources files with suffixes representing different languages. On the server, there is no AppGlobalResources folder. I deleted the vti_cnf folder from the server. I'm using the "Publish Web Site" with the "allow this pre-compiled site to be updateable" checked. I've never used the Web Site model before and am only used to working with Web Projects...

I've re-compiled and published the website but am still getting the same error message when clicking on settings in admin. This is not a biggie because I can use the settings panel locally. At this stage I'm just curious as to what's going on...

Thanks for your help :-)
Sep 14, 2007 at 6:47 PM
I'm having the same error when I publish the website...

[ArgumentException: Culture IETF Name zh-CN\_vti_cnf is not a recognized IETF name.
Parameter name: name]
System.Globalization.CultureInfo.GetCultureInfoByIetfLanguageTag(String name) +2288892
adminPagesconfiguration.BindCultures() +150
adminPagesconfiguration.Page_Load(Object sender, EventArgs e) +37
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +34
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1061
Sep 14, 2007 at 7:11 PM
This is still causing me problems.
Sep 14, 2007 at 9:18 PM
I have resorted to just copying the whole folder to the server vs. publishing the pre-compiled version. That said, if anyone has an idea of where the problem is I can go ahead and fix it.
Dec 11, 2007 at 9:48 AM
I am also having this exact problem. I use CrystalTech as my webhost.