has anyone installed blogengine.net in Godaddy Shared Hosting?!

Aug 8, 2007 at 2:30 AM
Hello all,
I am starter to blogengine.net. I downloaded the web package extracted and uploaded all the files to one of my site in godaddy. I tested the project in my local computer and it works fine. But it's not working in godaddy hosting. I set up new asp.net web application from godaddy's control panel giving every right necessary(read,write,set root etc.). When i enter the site... i can not see any error.. you can check that out from http://blog.kusadasilions.org/.Indicating that viewing errors are disabled. But I checked the default package and saw that its not...

Has someone installed blogengine.net in a Godaddy shared Hosting? Please answer me if you have.. At least I want to make sure that it can be installed..

Thank You
Aug 8, 2007 at 2:41 AM
Edited Aug 8, 2007 at 2:42 AM
I have found the reason and installed blogengine.net into godaddy hosting successfully... It worked successfully as i removed the line indicating the trust level. First of all sorry for opening the topic 2 times. Couldn t find a way to delete one.

Hope you all have a great day without buggies..
Aug 11, 2007 at 4:32 PM
Edited Aug 11, 2007 at 4:35 PM
removing trust level worked for me too but I am getting another error
URL: http://b.itsurday.com

can you tell what steps you have taken to install BlogEngine.Net on GoDaddy server.

Thanks.
Aug 11, 2007 at 8:26 PM
Go to your Godaddy control panel and make sure that /App_Data folder has read, write, execute...etc. access (check all options except for 'reset')

Looking at your error in your site, what else did you modify besides the security setting in the web.config?
Aug 11, 2007 at 10:18 PM
I didn't modify anything else other than removing trust tag from web.config file.

I have Deluxe Hosting account in GoDaddy, and how can I give read,write, execute access to /App_Data folder ?
Aug 11, 2007 at 11:37 PM
here are the steps,

  • upload all the files to a directory and keep the directory's name for further uses in godaddy.

  • from your godaddy hosting control panel.. open aspnet runtime menu there you create asp.net application by defining the root directry forexample.. if you have a directory "blog/" and your adress is like www.something.com/blog your application root should be there... you will see what am trying to tell after getting into that menu. Select read,write,browser,application root check boxes but not the reset checkbox.

after all these things your site should be working... if not write here again.. by the way .. it may be another error if you haven t created asp net application for your bloggernet create now and see what happens.. will be up all night.. let me know if this worked.

hope this helps,
cihan
Aug 12, 2007 at 2:21 AM
Thats why I wonder why cant I give any permissions. I dont see any 'Create asp.net application' button when I open my aspnet runtime page. I think I need to contact GoDaddy first.

:-Uday
Aug 12, 2007 at 9:21 AM
Edited Aug 12, 2007 at 9:22 AM
There is a misunderstanding ... there is no create asp.net application button under asp.net runtime page.. there is Create Directory button you should use that button to create a directory and indicate that.. that directory is going to be an application root..

hope this helps,
Cihan Necat KAVI
Aug 12, 2007 at 6:07 PM
Edited Aug 13, 2007 at 2:50 PM
i understood what you meant .. that there is some button to set permissions and I dont have it 'Create Directory' ( I didnt knew its name before )

I called up GoDaddy yesterday night and they said there is some problem with my account and inform me when its rectified. I am still waiting for their email.

Thanks,
Uday
Aug 13, 2007 at 3:07 PM
GoDaddy's reply:
"Custom ASP.Net Runtime Directory Permissions are disabled when FrontPage Extensions are installed."

So I uninstall FrontPage Extensions and created a custom directory 'b\App_Data' and set its permissions
and folder 'b' contains all the files related to BlogEngine.Net and modified web.config file ( changes: trust tag removed )
Runtime page:
http://itsurday.com/b/pics/runtime.jpg
Domain Management page:
http://itsurday.com/b/pics/dm.jpg

Now its give another error:
" It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS."

did I miss anything?
Aug 13, 2007 at 3:11 PM
Edited Aug 13, 2007 at 3:17 PM
I am Chinese ,please forgive my poor english.
Personally , I have try Godaddy Share hosting and DC Server, also have bad experience....
My Boss is UK man and he order me using Go daddy, but very bad, Godaddy suspend my DC Server and NOT ALLOW i backup my file.

I sure Blog Engine can be setup on Share Hosting
My Blog is using a HongKong Share Hosting service and work very well
only thing you need is have a Control Panel Like Plesk and set the App_Data folder permission for Blog Engine.
Aug 16, 2007 at 9:20 AM
Edited Aug 16, 2007 at 9:32 AM
I too was having trouble getting blogengine.net running on godaddy share hosting.
Here's what I did to get it working immediately.

ASP.NET environment
- Make certain your ASP.NET runtime is set to ASP.NET 2.0.
To set this, goto Control Panel: Settings-> ASP.NET Runtime.
Select the Content Root and change it to 2.0

BlogEngine.NET
Main Folder
- Log onto your godaddy account and go to your control panel
- Goto Control Panel: Settings-> ASP.NET Runtime.
- Click 'Create Directory'
- Enter a name for your directory, example 'blog'
- Check 'Read', 'Web', 'Set Root'
- Click 'Continue', Click Finish/OK/Update (whichever you have)

SubFolder
Wait for your blogengine.net folder (example 'blog') to be created. Once created:
- Goto Control Panel: Settings-> ASP.NET Runtime.
- Click 'Create Sub Directory' next to the name of your newly created folder
- Name it 'App_Data'
- Check 'Read', 'Web', 'Write'
- Click 'Continue', Click Finish/OK/Update (whichever you have)
This folder, 'App_Data', is the only folder that requires permission for the ASP.NET account to write to.

Fresh Installation
- I use FileZilla FTP Client (freeware, opensource) to connect to my godaddy site.
- Before copying the blogengine to your godaddy site, remove '<trust level="High" />' from the web.config as this is not allowed on godaddy accounts.
- Copy all files and folders for BlogEngine installation files, EXCEPT 'App_Data' to the newly created blogengine.net folder (my example folder is named 'blog')
- Copy all files and folders from 'App_Data' from the BlogEngine installation files into the same subfolder under your newly create folder on GoDaddy.

'Contact Me' Mail Configuration
- You will need to have Mail Accounts set up with godaddy for this to work. Refer to godaddy help on purchasing/configuring this.
- Once installed, log in (read blogengine documentation) to your site, go to 'settings', and use this smtp address 'relay-hosting.secureserver.net' instead of 'smtpout.secureserver.net' which did not work for me.

I'm new to blogengine.net and I've only just set it up at jquery.sanchezsalvador.com and I'm still trying to find my way.
hope this helps you.
Aug 16, 2007 at 8:01 PM
Thanks theahuramazda and everyone ... my blog is up.

I think the big mistake which I did was, creating blog and App_Data folders myself. I used to create the folder, upload the files and update the permission. It started working once I deleted everything and applied the settings first then upload the files.

"Happy blogging* !
Uday