This project is read-only.

More on IIS 7.0

Aug 10, 2007 at 7:14 PM
I'm having problems getting the latest to run on my machine (Vista/IIS 7) - and have read the discussions on the forum to try and find a solution. Nothing has worked so far - but I finally saw this in the documentation regarding the 500 error that I'm having on IIS 7.0:

"You may get an error as above, which suggests that you should run: %systemroot%\system32\inetsrv\APPCMD.EXE migrate config "site_name/BlogEngine" For once the instructions are correct... just open an admin command window, paste the command from your error message in there and run it."

I feel a bit dim for asking... but this statement just didn't make that much sense to me. Where do I need to run this from? The VS2005 Command Prompt? Also, what should replace "site_name" in the given example?

If someone would be so kind as to hold my hand a little bit - I'd appreciate it.

To be thorough... here's the error I'm getting when I bring up the site: (localhost/BlogEngine/default.aspx)

HTTP Error 500.19 - Internal Server Error

Description: The requested page cannot be accessed because the related configuration data for the page is invalid.

Error Code: 0x80070005

Notification: BeginRequest

Module: IIS Web Core

Requested URL: http://localhost:80/BlogEngine/BlogEngine

Physical Path: C:\Users\Chad\dev\tools\BlogEngine.NET\BlogEngine

Logon User: Not yet determined

Logon Method: Not yet determined

Handler: Not yet determined

Config Error: Cannot read configuration file

Config File: \\?\C:\Users\Chad\dev\tools\BlogEngine.NET\web.config

Aug 10, 2007 at 9:10 PM
1. Locate "Command prompt" shortcut in Start menu
2. Right click on it -> Run As administrator
3. Run iis.msc
Here is your site_name (Default name is "Default Web Site")
4. Run %systemroot%\system32\inetsrv\APPCMD.EXE migrate config "site_name/BlogEngine"
Aug 10, 2007 at 10:32 PM
Gotcha, thanks!

Got these messages:

Successfully migrated section "system.web/httpModules".
Successfully migrated section "system.web/httpHandlers".

But still get the same 500.19 error as before - no change.

Any ideas?

Thanks again.