New User Issues

Aug 15, 2007 at 6:11 PM
Edited Aug 15, 2007 at 7:47 PM
Okay... I'm very excited that I just found out about BE on Monday - was able to install it on Tuesday and now that it's Wednesday I've implemented a custom theme! However, testing shows some problems.

  • I run VisualStudio 2005 on Vista with IIS7 and have been unable to get my site to preview locally. I've checked my IIS Manager and I've got both App_Data and blog (my BE directory) setup as Applications. I've also made sure the directories have both USER and ASPNET with full permissions.

  • The site is hosted on GoDaddy, and I've gone into the Control Panel there and made sure that both App_Data and blog have Read, Write, Browse, Web, and Set Root permissions. According to them, this makes the directory into an application. I've also commented out the Trust Level in Web.config in the blog directory.

    • When I try to Save a New Post, I get:
// multi-line
 
Server Error in '/blog' Application.
--------------------------------------------------------------------------------
Access to the path 'd:\hosting\xxxxxxx\blog\App_Data\posts\xxxxxxxxxx.xml' is denied. 
and the Comment is NOT saved.

    • When I try to Save a Comment, the spinner keeps going! However, if I move around, the Comment IS saved.

Well, if anyone can shed any light on these issues, I'd be very grateful!
Aug 16, 2007 at 1:26 PM
Can anyone offer any assistance???
Coordinator
Aug 16, 2007 at 1:28 PM
You need write access to the app_data folder
Coordinator
Aug 16, 2007 at 1:29 PM

MrBruce wrote:
Can anyone offer any assistance???


Look at http://www.dotnetblogengine.net/wiki/Installation.ashx#D_-_Fresh_installation_
Aug 16, 2007 at 2:47 PM


madskristensen wrote:
You need write access to the app_data folder


Mads, I have just double checked... both the "blog" directory (where I installed BE) and the "App_Data" subdirectory have Read, Write, Browse, Web, and Set Root enabled, so, according to GoDaddy, they should be set as applications.

The Web.config file has had the trust level line removed. I'll gladly provide you access if you'd be willing to take a look... email me and I'll provide UserName and Password.

This is driving me crazy!

The installation is here http://http://lancekenman.com/blog/ and as you can see, the blog page is there... I just can't do anything with it yet...........
Aug 16, 2007 at 2:48 PM


Been there... read the instructions, followed them, and I still can't blog. :(
Aug 16, 2007 at 5:46 PM
Edited Aug 16, 2007 at 5:48 PM

madskristensen wrote:
You need write access to the app_data folder


Having heard this several times, I went back and re-examined the hosting at GoDaddy. Guess what? I had two App_Data folders - one at the root where I'd placed the "correct" permissions, and another within my blog directory. I removed the one at the root, and deleted it from the Control Panel at GoDaddy. For the benefit of others, here's how it should be set up!

GoDaddy Setup


Control Panel > Content > Directory Management*

  • Check the Content Root area to be sure it's set for ASP.NET 2.0
  • If there are no Custom Directories, create them (if there ARE, be sure you've set them up like this!) as follows:

    • blog (or whatever directory you installed BlogEngine.NET into) -- click all the boxes except the last one... Read, Web, Browse, Write, and Set Root should be clicked. Click on Continue > Update and then refresh your screen every few minutes until you see "SETUP" under Status.
    • Then click "Create Sub-Directory" and enter App_Data in the text box following whatever is pre-filled there. Set the permissions the same as above and follow theinstructions until it shows "SETUP" under Status.

Also, be sure you've gone into your blog directory and edited the Web.config there to remove the line under <system.web> that says <trust level="High" />.

  • If you don't see a Directory Management icon here, go back to Settings > FrontPage Extensions and uninstall them!

Hope that helps you out!