Full URI for embedded links/pics in posts?

Aug 30, 2007 at 2:09 PM
Whenever I add a link in a post that points to a page within the same domain space, it removes the URL and only keeps /post.aspx?id=xxxxx. Whenever I use feedburn, those links (and images too for that matter) gets translated to http://feeds.feedburner.com/post.aspx?id=xxxxx when people are consuming the posts via a reader. Is this by design or is there some workaround? I believe there was some html/header code, so I added this in the head section:

<base href="http://www.MyDomain.com/sub" />

But the Feedburner still convert those embedded (forced relative) links in posts incorrectly. Even when I hardcode the link (and images) to the full URL, BE.NET makes them relative again. Suggestions very welcome!
Sep 3, 2007 at 2:15 PM
Can BE.NET use the full URI of an internal link (i.e. to another post in own blog) instead of just the relative path? (e.g., /post/cool-title.aspx)

I'm asking because those links & pics in posts won't work if Feedburner is used. Thanks and sorry for the repost.
Sep 3, 2007 at 3:54 PM
I second that question. I was under the impression, however, that this was the editor that was doing this, and not so much BE.NET itself.

Open up /admin/tinymce/tinymce.js and find convert_urls

Change the first instance from "convert_urls",true to "convert_urls",false

(let's hope that underscore doesn't get converted ...
Coordinator
Sep 3, 2007 at 5:00 PM
This is something we'll look at in the RSS code. I still want to keep relative urls in the posts on the site.
Oct 20, 2007 at 5:13 PM
Any progress on this issue? I'm experiencing the same problem with Feedburner
Coordinator
Oct 20, 2007 at 11:02 PM
It has been fixed in the 1.2 release
Jan 18, 2009 at 4:38 AM
It seems this is still broken for pages.   I'm using the 1.4 version and absolute <img> tags are converted to relative links.