Anyone tried on x64 system?

Sep 6, 2007 at 8:35 AM
Hello,

I copied blogengine web project version to win2003 x64 system and set it up, but browser showed "404 error" msg. I tried vary ways, however, failed to launch. As I tried with same way on another x86 machine, it goes on well. Is there something issue on x64 system? On x64 system, I set it with minimal settings. IIS, .net framework, Virtual Server, that's all I installed. VS's administrative site is works correctly, so it seems not IIS's problem...


kenial
Sep 6, 2007 at 1:07 PM
Check the permissions on you App_Data folder. Windows 2003 is much more restrictive than XP.

It's may not be the right fix, but I had to give write permissions to IUSR_machine to get the xml based blog to run. I've now switched to the SQL provider.
Coordinator
Sep 6, 2007 at 8:41 PM
x64 doesn't have other rules in the asp.net runtime. What runs on x86 also runs on x64. It must be something else
Sep 6, 2007 at 11:54 PM
So, isn't there anyone have BE works correctly on Win2003 x64 edition?
Sep 7, 2007 at 1:20 AM
Double check that the
*application pools are all .Net 2.0 websites
*make sure the site is set for .Net 2.0
*make sure the default page is default.aspx
*Set the permissions on the app_data to read/write and leave the rest of the folders alone.

Sometimes these are not set. Just some thoughts.
Sep 7, 2007 at 3:55 AM
Yes, I checked it out all.
Sep 7, 2007 at 5:04 PM
Hi!

I had the same problem so I commented out the following line from web.config file:

<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule"/>

It solved the problem. I think if after that you disable the subdomain redirection policy from admin config and remove the comment, it will still work.

Hope this helps out in your problem too.