I think I found a bug.

Topics: ASP.NET 2.0, Business Logic Layer, Controls
Sep 12, 2007 at 9:49 PM
When I use special Turkish characters in the title of an entry, it first gives an error saying something like "the page you requested was not found", however if I go to home page the entry is there. When I click the title the same error again :( I think the problem occurs while using these characters to establish a link to the entry. Thus, the titles have to be with English alphabet. Is this a known issue or did I just catch it or am I doing something wrong?

Special characters in Turkish : çÇ ğĞ ıİ (attention to dots) öÖ şŞ üÜ

Best Regards,
Engin Uysal
Coordinator
Sep 13, 2007 at 1:10 PM
What version of BlogEngine.NET are you running?
Sep 13, 2007 at 4:35 PM
Sorry, I forgot to write that. It's 1.1.0.7

madskristensen wrote:
What version of BlogEngine.NET are you running?

Sep 13, 2007 at 7:29 PM
Edited Sep 13, 2007 at 7:30 PM
Ya,
Some symbol Like
" & "
" @ "
" % "
it will be show "the page you requested was not found",same there the entry is wrote.
But for Chinese characters, it have not problem.
i am using 1.1.0.7 too.
Coordinator
Sep 13, 2007 at 8:06 PM
That has been fixed since the 1.1 release which was called 1.1.0.7.
You can get the fix by downloading the latest source code or wait a few weeks for the 1.2 release
Sep 14, 2007 at 6:46 PM
I played with it a little bit after you wrote that and found something. If the text (main body text, not subject) is short, the special characters don't make any problem. However, the problem raises again when I send a long text.
Regards,


madskristensen wrote:
That has been fixed since the 1.1 release which was called 1.1.0.7.
You can get the fix by downloading the latest source code or wait a few weeks for the 1.2 release

Sep 14, 2007 at 6:55 PM
By the way, I found quite a wonderful sentence written by you in the history. Is that "read more" thing going to be in 1.2 release?


madskristensen wrote:
vrivero, a summary of a post with a "read more" link at the bottom will be included in the next release.

Coordinator
Sep 14, 2007 at 7:20 PM
Yes, insert the text more and it will cut your post and insert Read more... as a link. 1.2 will have this feature.