Blog has died

Sep 14, 2007 at 2:06 PM
My blog has suddenly died - http://www.outofmemory.co.uk

I am running BlogEngine.net 1.1 and am using the SQL as the data store.

The blog has been running fine for weeks now. Yesterday, I had my first comment since I migrated, but everything worked fine.

This morning however, the website is displaying an ugly error about comments http://www.outofmemory.co.uk (displayed on the website - Object reference not set to an instance of an object). The strange thing is, I have not updated the blog, and no more comments have been added since yesterday so I am at a loss as to why the blog has suddenly stopped working.

Any ideas?
Sep 14, 2007 at 3:31 PM
yes, i also have this problem
my solution is ,edit the web.config with some dummy (Just modify and save)
Then blogengine will recompile the whole application
Sep 14, 2007 at 4:12 PM

Ming wrote:
yes, i also have this problem
my solution is ,edit the web.config with some dummy (Just modify and save)
Then blogengine will recompile the whole application


I gave this a go, but it sadly didn't make any difference. I still get the error.

Any ideas?
Sep 15, 2007 at 10:10 AM
Edited Sep 15, 2007 at 10:13 AM
I opened up the website in debug this morning and tracked down the problem to the Blog SQL Provider. I made a fix, and did a retrospective search of the issue list, and found this bug had already been found:-

http://www.codeplex.com/blogengine/WorkItem/View.aspx?WorkItemId=2840

Fix: At line 106, The following line needs to be added: comment.Post = post;

Wish I had found this first :)

BlogEngine team - Is there a case for including these sort of fixes as a minor update? This bug basically stops any 1.1 blog from working under the ms sql provider?
Coordinator
Sep 15, 2007 at 4:06 PM
No there is not unfortunately. However, the 1.2 release is only few weeks away now. Sorry for you trouble on this issue. We've done much to improve the overall quality for the 1.2 release so these sort of bugs doesn't occur again.