Strange Error out of the Blue (BlogEngine.Core.Providers.XmlBlogProvider.SelectPost)

Oct 10, 2007 at 5:33 AM
I uploaded version 1.1 to our website a while back, and today when i logged on to check on things i get these weird errors(i hadn't made any changes myself, they seemed to come out of nowhere and i'm stuck as to why there there)

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 42: {
Line 43: int number = BlogSettings.Instance.NumberOfRecentPosts;
Line 44: if (number > Post.Posts.Count)
Line 45: number = Post.Posts.Count;
Line 46:

NullReferenceException: Object reference not set to an instance of an object.
BlogEngine.Core.Providers.XmlBlogProvider.SelectPost(Guid id) +434
BlogEngine.Core.Providers.BlogService.SelectPost(Guid id) +42
BlogEngine.Core.Post.DataSelect(Guid id) +32
BlogEngine.Core.BusinessBase`2.Load(KEY id) +94
BlogEngine.Core.Providers.XmlBlogProvider.FillPosts() +194
BlogEngine.Core.Post.get_Posts() +67
Controls.RecentPosts.BuildPostList() in c:\....RecentPosts.cs:44
Controls.RecentPosts..cctor() in c:\...\App_Code\Controls\RecentPosts.cs:22

Any ideas?
Oct 21, 2007 at 4:13 PM
Edited Oct 21, 2007 at 4:14 PM
I have the same problem after upgrading to 1.2. The problem goes away if I delete all the entries from the posts folder (this is not desirable of course).