This project is read-only.

Please Help

Oct 16, 2007 at 5:21 PM
I am attempting to set up BlogEngine. All I hear is how easy it is. I have tried a few things now and can only run it on my localhost not on the server. I am getting a run time error you can see this at I tried to set it from High to Medium but that seemed to have no effect. Can anyone tell me what is going on there?
Oct 16, 2007 at 5:32 PM
You have to remove "<trust level="High" />" tag all together; your hoster handles this on machine level and does not allow overrides.
Oct 16, 2007 at 6:05 PM
I commented it out, and now it's giving me an error having to do with not having a re-direct page. It's at I use it for a test page for apps on my server. Now it looks like it is just telling me to put a custom error page, but I don't want one because I want to see the runtime error. I don't see how turning the customError mode on would make much of a change in it not working would it?
Oct 16, 2007 at 7:39 PM
It shouldn't be in the web.config of a release anyway. If BlogEngine.NET is medium trust compatible there is no reason to have a high trust switch in the config file. It just generates more support issues.
Oct 16, 2007 at 8:24 PM
Edited Oct 16, 2007 at 8:24 PM
I've managed to get to a new Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. (\\smb0\mnt\w1008\d06\s01\b02bd07b\www\\web.config line 76)

Source Error:

Line 74:
Line 75: <httpModules>
Line 76: <add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite"/>
Line 77: <add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule"/>
Line 78: <add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule"/>

Source File: \\smb0\mnt\w1008\d06\s01\b02bd07b\www\\web.config Line: 76

Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.210
Oct 16, 2007 at 8:35 PM
That’s an interesting path: \\smb0\mnt.. Are you running it on MONO?
Oct 16, 2007 at 9:00 PM
I am using Netfirms, I hope it's not MONO, I have no problem with it, I just have had problems with it in the past and the reason I went there was to use .net as opposed to linux like my other sites. I have a little server look up bar on my browser and it says it is Microsoft IIS/6.0 Wouldn't it say Apache or something it it were on mono?
Oct 16, 2007 at 9:24 PM
I would try “hello world” or something, with web config pretty much empty - just to make sure environment is set up properly. That samba mount looks odd.