BlogEngine.NET & Mono

Topics: ASP.NET 2.0
Developer
Oct 31, 2007 at 7:49 PM
I've managed to get BlogEngine.NET running on Ubuntu using apache2 and mod_mono. There are still some oddities which I'm working on sorting out though.

The url is http://blog.ruski.co.za.

A list of changes that were made is available here: http://blog.ruski.co.za/admin/Pages/page/BlogEngineNET-Modifications-for-MonoLinux.aspx. I'll keep updating it as I sort more issues out.

I'd be happy to assist in getting proper Mono support in the release versions of BlogEngine.NET, so let me know if there is anything else I can do!
Oct 31, 2007 at 8:04 PM
Nice work!
Oct 31, 2007 at 10:10 PM
Nice work I was thinking about goofing around with doing the conversion, but guess I don't need to worry about it.
Developer
Oct 31, 2007 at 10:26 PM
I wish you'd done it before I got to it :) Being a Linux noob has made this conversion one of the most frustrating things I've ever attempted.

If the developers agree, I will make the source available. The list of changes is really only for the developers so they have a reference of the changes necessary to support mono.
Feb 18, 2009 at 6:29 PM
Any luck with getting the url re-writing to work with Apache and mod-mono?
Developer
Mar 9, 2009 at 8:30 AM
Yeah, I did finally get that fixed on the new release.

Mar 10, 2009 at 12:47 AM
Edited Mar 10, 2009 at 12:48 AM
I just wrote a little article today that gives an example of a VirtualHost file using mod_mono for setting up blogengine.  If you don't set up the VirtualHost correctly requests never even make it to the mono_server.   Also I am running openSUSE with mono 2.2 and so far I haven't run into any errors with BlogEngine other than my VirtualHost file needing to be changed.  Below is the article

http://blog.runxc.com/post/2009/03/09/ASPNET-style-URL-rewriting-with-Mono-and-mod_mono-and-apache2.aspx