Trackbacks to other places not working?

Nov 12, 2007 at 2:24 AM
Hi there,

My blog doesn't seem to be sending out trackbacks to other blogs. For example, http://blog.domenicdenicola.com/post/2007/11/Criteria-for-a-Theory-of-Everything.aspx should be sending out a trackback to http://arxiv.org/tb/0711.0770, but no such trackback shows up. Similarly, http://blog.domenicdenicola.com/post/2007/10/The-Dirac-Sea-and-Quantum-Field-Theory.aspx should be sending out a trackback to http://dorigo.wordpress.com/2007/10/18/guest-post-rick-ryals-diracs-holes-and-einsteins-constant/, but there is no such trackback.

I might not be understanding the trackback system, but I'm pretty sure that BlogEngine.NET is supposed to do this automatically?

(Note: I don't think anyone's linked to my posts, so trackbacks to my blog from other places might be working fine.)
Nov 12, 2007 at 4:43 AM
Maybe this is connected that the RDF code in post.aspx is commented out? But then again, it's commented out on Mads's site as well... so that's probably intentional...
Coordinator
Nov 12, 2007 at 6:27 PM
I've done some investigation and I found the solution. It appears that the sites you mention where the trackback wasn't registered is rejecting trackback requests without a user agent. By setting the user agent string in the web request BE performs, it now works. I've made the change in the latest change set. Thanks.
Coordinator
Nov 12, 2007 at 7:41 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.