allowDefinition='MachineToApplication'

Topics: ASP.NET 2.0, Business Logic Layer
Dec 12, 2007 at 12:41 PM
Please forgive me, I am new to the BlogEngine and somewhat new to DOT NET. I have an existing web project that I am trying to add the Blog Engine. I have followed the instructions for installing the software and confirmed that the blog directory is setup as a virtual directory and setup as an application in my local IIS. However, now when I try to build the project in order to publish it, I receive the following errors:

It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.

And

'requirePermission' attribute is not declared. C:\Inetpub\wwwroot\TWiCommunicationSite\blog\Web.Config

Any help would be greatly appreciated.
Dec 12, 2007 at 2:45 PM
On my PC, in IIS, under Default Web Site, I created a 'New Application'. I selected the physical path where my blog is located on my PC. At this point, I had the same problem and was able to resolve it by selecting 'Classic .Net AppPool' under Behavior/Application Pool. Hopefully that helps you out.
Dec 12, 2007 at 5:20 PM
james,

Thanks for the reply....I am running Windows XP...where is the setting 'Classic .Net AppPool' under Behavior/Application Pool in the IIS manager


jaimes wrote:
On my PC, in IIS, under Default Web Site, I created a 'New Application'. I selected the physical path where my blog is located on my PC. At this point, I had the same problem and was able to resolve it by selecting 'Classic .Net AppPool' under Behavior/Application Pool. Hopefully that helps you out.