This project is read-only.

Change Set 8627 broke!

Dec 17, 2007 at 12:21 AM
So I decided to get the latest code, and 8627 is broke.

Let me first say I do appreciate the work you all do on the core team... but it seems like EVERY time I pull a build not from Mad's it is critically broken.

Shouldn't the policy be that the releases on the Source Code tab should work...???
Dec 17, 2007 at 2:15 AM
It would probably be a good idea to mention what is broken. No, releases on the Source Code tab should not always work, releases on the releases tab should (otherwise there wouldn't be seperate tabs).
Dec 17, 2007 at 4:11 AM
I would actually hope that the actual team members disagree with you about it being broken on the source code tab. If not, then it will change how I consume new builds... but in that regard grabbing one from somebody other than Mads was something out of character for me... generally (due to the bad luck with other builds) I only grab builds from him. I understand that source code releases may have bugs, but they shouldn't break out of the box. Not even load up.... it was bad.

Once I broke the build locally, I didn't care enough to keep the screen up and post the exact reason. If they want it they can download it and get it. It was based on the extension manager stuff. I was more focused on getting my build fixed.

And if the team members do agree with you that broken builds on that tab are ok, then I ask them to mention in the description when that is the case. For two reasons:
1. Merging in something only to find out it is broke... sucks!
2. I bet a lot of first time users, use that tab for the release... and for their first experience to be a broken build doesn't help the public perception of this blog engine.
Dec 17, 2007 at 4:44 AM
Edited Dec 17, 2007 at 4:52 AM
Actually, build runs just fine. I downloaded and tried to brake it for half an hour on my local machine - it still works. So, what exactly is broken?
Dec 17, 2007 at 5:03 AM
Honestly don't have the time, nor care enough to download it and tell you the error I get. Was just posting it here for reference...

I dropped back to 8624 and it works like a charm for me. I've generally take the time to upgrade to 'the latest version' once a week, so I know what I'm doing. I even tried merging 8627 in twice, both times it failed.

No biggie if it works for everybody else... but its broke on my machine ;-)
Dec 17, 2007 at 5:24 AM
Well I'm a fair guy.. went ahead and stayed up later then I should have and retried the latest code (base install, no extensions)... decided to work this time. Honestly not caring enough to figure out the difference. But I'm a fair guy and figured I'd post this here.
Dec 17, 2007 at 5:25 AM
That's ok. If anybody else will run into problem with 8627 please let me know.
Dec 17, 2007 at 5:42 PM
We have a policy that no one checks in code that doesn't compile and so far none has. My best bet is that it is the differences in the Team Explorer and SVN clients and how they work on CodePlex that is causing the trouble.