This project is read-only.

Lot of comment spam since update to 1.6

Mar 9, 2010 at 9:05 AM

Hi there,

Just updated my blog to version 1.6 this weekend. It was easy and done without any pain - good job guys. Only one problem is left: since the update I got a lot comment spam (about 5-10 spam comments per day). I configured the comment system like this:

  • Moderated: true
  • Moderation-Mode: Automatic
  • Rules:
    • Trust auth. user: true
    • Add to whitelist... : 1
    • Add to blacklist...: 1
    • Block on delete: false
  • Filters: none
  • Custom filter:
    • AkismetFilter: true (configured with my own API-Key and the URL using the extensions)
    • StopForumSpam: true
    • Report mistakes back to server: true

With this configuration in place I still get 5-10 spam comments per day sent to the moderator email for ("Delete" / "Approve") where I have to cluck "Delete". With version 1.5 I had the Akisment-Extension in place which did a pretty good job then.

Does anybody see something not good in this configuration? If the configuration is ok how can one improve the spam detection with version 1.6? Are there any good extensions out there for version 1.6 that do improve the spam-detection further?

Thx for help!


Mar 9, 2010 at 2:22 PM

Checking the stats of the custom filters shows that Akismet does a good job but the StopForumSpam does approve nearly everything. Can this somehow be changed? Can StopForumSpam somehow be configured? How does StopForumSpam work?

Mar 9, 2010 at 2:27 PM

A quick search would have led you to this thread:

I get about one spam message every three to four days.

Mar 9, 2010 at 3:14 PM

Thanks, maybe that will be a final solutions. At the moment I feel like I don't really understand the "StopForumSpam" and the custom filters and their priority at all. I try to understand why Akismet would flag most of the spam successfully as spam but StopForumSpam doesn't so finally they are not spam. Why doesn't it matter Akismet recognize them successfully as spam? Reading other topics in the forum here I found that the falling-through is kind of special. So I tried to change the order of the custom filters and test if that solves some issues. I found that one needs to delete the stopformspam file on the server to disable it. But before doing this I like to understand things. So far I did not found a lot of information how the custom filters list should be used probably.

Mar 9, 2010 at 4:57 PM

Here is some read on custom filters in 1.6

Mar 10, 2010 at 7:28 AM

Thanks a lot. This was the missing peace of information how this (should) work. ;-)