Configuration Error

Topics: ASP.NET 2.0, Business Logic Layer
Jan 15, 2008 at 9:59 PM
I've installed the blog code into a folder called /taxnews and I made the folder as an application. I also have aspdotnetstorefront installed in the root. For some reason I'm getting this error:




Server Error in '/taxnews' Application.
--------------------------------------------------------------------------------

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'AspDotNetStorefrontCommon' or one of its dependencies. The system cannot find the file specified. (C:\AspDotNetStorefront\web.config line 398)

Source Error:


Line 396: <httpModules>
Line 397: <!--<add name="gago" type="DumperHTTPModule,app_code"/>-->
Line 398: <add name="AuthenticationModule" type="AspDotNetStorefrontCommon.InterpriseIntegration.Authentication.RestrictedResourceAuthenticationModule,AspDotNetStorefrontCommon"/>
Line 399: </httpModules>
Line 400: <webServices>


Source File: C:\AspDotNetStorefront\web.config Line: 398


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

To me looks like the web.config I have on the root is conflicting with the web.config I have under my blog folder.

Please help!

Thank you!
Jan 15, 2008 at 10:55 PM
Edited Jan 16, 2008 at 8:24 AM
Hi, seems like a conflicting root web.config indeed. You have at least these two options:

Option 1: Remove the specific module in the BlogEngine web.config:
<httpModules>
   ...
   <remove name="AuthenticationModule"/>
   ...
</httpModules>
If you're sure that none of your subfolders / child applications depend on your root web.config, then you might consider this alternative:

Option 2: Block inheritance of (and in) root web.config:
<location path="." inheritInChildApplications="false">
   <system.web>
   ...
   </system.web>
</location>
Did one of these options help?
Jan 16, 2008 at 4:46 PM
The <remove name="AuthenticationModule"/> fixed it. Thank you MikevZ !



MikevZ wrote:
Hi, seems like a conflicting root web.config indeed. You have at least these two options:

Option 1: Remove the specific module in the BlogEngine web.config:
<httpModules>
   ...
   <remove name="AuthenticationModule"/>
   ...
</httpModules>
If you're sure that none of your subfolders / child applications depend on your root web.config, then you might consider this alternative:

Option 2: Block inheritance of (and in) root web.config:
<location path="." inheritInChildApplications="false">
   <system.web>
   ...
   </system.web>
</location>
Did one of these options help?

Jan 16, 2008 at 5:26 PM
You're welcome Bobococo, I'm glad to hear it's fixed. Thanks for letting us know!

bobococo wrote:
The <remove name="AuthenticationModule"/> fixed it. Thank you MikevZ !