This project is read-only.

Can't Find Page timeout?

Topics: ASP.NET 2.0
Mar 24, 2010 at 7:12 PM

I know there are plenty of Oops! Cant find page...issues on here, but I searched and couldn't find an answer to my issue. 

If I stay on one page for more than a minute or so, then click another link, I get the "Can't find page" error. However, if I click on that exact same link again, I can get to the page I was trying for. 

I went in the web.config file and set customerrors to "off" and here is the error I'm continuously getting:

Server Error in '/' Application.

Access to the path 'D:\hshome\oscmedia\\App_Data\datastore\extensions\AkismetFilter.xml' is denied.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.UnauthorizedAccessException: Access to the path 'D:\hshome\oscmedia\\App_Data\datastore\extensions\AkismetFilter.xml' is denied. 

ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity. ASP.NET has a base process identity (typically {MACHINE}\ASPNET on IIS 5 or Network Service on IIS 6) that is used if the application is not impersonating. If the application is impersonating via <identity impersonate="true"/>, the identity will be the anonymous user (typically IUSR_MACHINENAME) or the authenticated request user. 

To grant ASP.NET access to a file, right-click the file in Explorer, choose "Properties" and select the Security tab. Click "Add" to add the appropriate user or group. Highlight the ASP.NET account, and check the boxes for the desired access.



I checked and that extension wasn't even enabled. Is this just a permissions issue that's causing the whole site to act up?

here is the link to the blog if you want to see the issue:

If you let it sit for a minute (probably closer to 30 seconds) and click a link, it will ask you to login to the server. Just hit cancel and you can see the error message.

Mar 25, 2010 at 12:37 AM

Yes, it looks like a simple permissions issue.  I would make sure that Write permissions are set on the App_Data folder.

Mar 25, 2010 at 2:21 AM

Ok. I'm working with my Host at IX Webhosting. I think I've got it set correctly, but it's a bit confusing to set this stuff with IX.