error CS0433: The type 'ManagedExtension' exists in both ...

Topics: ASP.NET 2.0, Themes
Mar 26, 2010 at 9:41 PM
Edited Mar 26, 2010 at 9:49 PM

Hi ... having the above problem.

I had v1.4.5.0 and it was working well. The reason I wanted to upgrade is that I was getting (automated) comments being posted (SPAM). I decided to update to the latest 1.6 version and followed the installation instructions. I am now getting errors. I have tried the following:-

  • Deleting the Extentions Manager folder
  • Tried finding these but the theme I used "Darkblog" did not have any. I subsequently used the default theme just in case.
    Replace #widgetzone with .widgetzone
    Replace #widgetselector with .widgetselector
  • When I uploaded the new version I overwrote all files beside the Settings file in APP_DATA, which I have replaced since.
  • APP_DATA has FULL Permissions which I set via IIS (v6). I also set it via Sharing and Secturity
  • The only other file I have not written over is the XML file containing the my pervious POSTs.
  • My .net engine version is 2.0.50727
  • The blog folder is set to Application as well. Remember v1.4.5.0 was working well.
  • Have deleted the web.config file and reuploaded from the v1.6 unzip folder.

 

The Error message I get after uploading v1.6 is the following : -

Message : c:\Inetpub\wwwroot\domainFolder\blog\admin\Extension Manager\Extensions.ascx.cs(41): error CS0433: The type 'ManagedExtension' exists in both 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\blog\826379c6\e423c7da\assembly\dl3\9f93aefa\60355b5d_23ccca01\BlogEngine.Core.DLL' and 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\blog\826379c6\e423c7da\App_Code.mvozgfsv.dll'

I would appreciate any assistance.

Thanks

 

PS: I am using Windows 2003 Server so the Account with FULL Persiossions is "Network Service"

Coordinator
Mar 26, 2010 at 11:32 PM

Check out this thread.