Trouble with fresh install: "Object reference not set to an instance of an object."

Jan 26, 2008 at 6:45 PM
After doing a clean install, logging in, and trying to post new items I allwas get this error message:

It also shows up if I try to click on one post to see it.

Server Error in '/' Application.

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

Line 361: {
Line 362: MembershipUser user = Membership.GetUser();
Line 363: txtName.Text = user.UserName;
Line 364: txtEmail.Text = user.Email;
Line 365: txtWebsite.Text = Request.Url.Host;

Source File: d:\home\dampno\subdomener\ole\User controls\CommentView.ascx.cs Line: 363

Stack Trace:

NullReferenceException: Object reference not set to an instance of an object.
UsercontrolsCommentView.GetCookie() in d:\home\dampno\subdomener\ole\User controls\CommentView.ascx.cs:363
UsercontrolsCommentView.Page_Load(Object sender, EventArgs e) in d:\home\dampno\subdomener\ole\User controls\CommentView.ascx.cs:141
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +33
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Control.LoadRecursive() +131
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1436

Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433


Hope anyone can help
Best regards,
Ole Losvik
Jan 27, 2008 at 10:37 AM
I have installed the latest release (1.3), using shared hosting on IIS6 and 2.

Will it help to try to configure the sql provider?
Jan 27, 2008 at 12:39 PM
Edited Jan 29, 2008 at 10:29 AM
The error is associated with the change of username i have just noticed. After logging out, waiting, and clearing all cookies, there was no problem anymore.