'BlogEngine.Core.BlogSettings' does not contain a definition for 'Moderation'

Apr 28, 2010 at 8:36 PM

I updated a clean build of 1.6 with the 1.6.1 refresh, and I received the posted error. At first I updated only the files outlined on the BlogEngine homepage, and when I got a Disqus error, I tried overwriting the entire BlogEngine.NET directory with the new files - the Disqus error went away but I still get that compile error (Error 3 'BlogEngine.Core.BlogSettings' does not contain a definition for 'Moderation').

 

What did I do wrong? 

 

Coordinator
Apr 29, 2010 at 5:43 AM

There's a new DLL that goes into the BIN directory.  Make sure you're using the DLL that comes with BE 1.6.1.

May 12, 2010 at 6:48 PM

Any ideas as to when the source version might be released?  I have a bit of custom code that I'd like to incorporate into the dll before upgrading.

Coordinator
May 12, 2010 at 7:46 PM

You can download the Source version of any version including 1.6.1 on the Source Code tab above.

Jun 10, 2010 at 4:59 AM

I am unable to find source version of 1.6.1 under source tab.  It include only BlogEngine.NET 1.6 (source).  Can anybody tell from where I can download it because I am facing the same problem as listed above?