Install under existing .NET application

May 7, 2010 at 4:00 AM

I am trying to install BlogEngine with my Able Commerce E-commerce site. I can't get it to work. My host provider says there are too many conflicts with Able Commerce.  I know of other AC sites that are running BlogEngine under their AC site.  I am told that editing the Web.config file is needed.  Does anyone know specifically what edits are needed?

You can see the error codes when trying to load my blog at:

http://www.contractors-solutions.net/blog/

 

Here are examples of other sites that have accomplished this type of install:

http://www.pizzaovens.com/Blog/

 

http://www.ablemods.com/blog/

Any help would be appreciated,

Scott

 

Coordinator
May 7, 2010 at 11:32 AM

In the web.config file in the root directory (the web.config file for Able -- not the BE web.config file), I would wrap the existing <system.web> and <system.webServer> sections in the following location tags.

<location path="." inheritInChildApplications="false">
          <system.web>
                      ............ existing content .............
          </system.web>
</location>

<location path="." inheritInChildApplications="false">
          <system.webServer>
                      ............ existing content .............
          </system.webServer>
</location>

(you may or may not have the <system.webServer> section)

This will prevent settings from propagating down to sub-applications like BE.

May 8, 2010 at 2:08 AM

Thanks a lot. It worked like a charm, and I don’t even know anything about programming or XML.
I will share this on the Able Commerce forum so others will know how to use BlogEngine with AC.


Thanks,

Scott

Contractor's Solutions

workwear, construction tools, truck racks