Error 404/ IIS7

May 11, 2010 at 4:58 PM

Been trying to resolve this issue for a while and I can't get it working. I've replaced my web.config file multiple times with different configuration settings and I still get the 404 error when I try to edit posts or make comments e.t.c.. Heres what my config file looks like now:

<?

xml version="1.0" encoding="UTF-8"?><

configuration><

configSections><

sectionGroup name="BlogEngine"><

section name="blogProvider" requirePermission="false" type="BlogEngine.Core.Providers.BlogProviderSection, BlogEngine.Core" allowDefinition="MachineToApplication" restartOnExternalChanges="true" /></

sectionGroup></

configSections><

BlogEngine><

blogProvider defaultProvider="XmlBlogProvider"><

providers><

add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core" /><

add name="DbBlogProvider" type="BlogEngine.Core.Providers.DbBlogProvider, BlogEngine.Core" connectionStringName="BlogEngine" /></

providers></

blogProvider></

BlogEngine><!--

configSource is not implemented in Mono.<connectionStrings configSource="sql.config" />

--><

connectionStrings><

clear /><

add name="LocalSqlServer" connectionString="dummy" /><!--

Mono complains if LocalSqlServer isn't specified --><

add name="BlogEngine" connectionString="Data Source=MySQLServer;User ID=user;Password=password;persist security info=False;initial catalog=BlogEngine;" providerName="System.Data.SqlClient" /></

connectionStrings>

<

appSettings><

add key="BlogEngine.FileExtension" value=".aspx" /><!--

You can e.g. use "~/blog/" if BlogEngine.NET is not located in the root of the application --><

add key="BlogEngine.VirtualPath" value="~/" /><!--

The regex used to identify mobile devices so a different theme can be shown --><

add key="BlogEngine.MobileDevices" value="(nokia|sonyericsson|blackberry|samsung|sec\-|windows ce|motorola|mot\-|up.b|midp\-)" /><!--

The name of the role with administrator permissions --><

add key="BlogEngine.AdminRole" value="Administrators" /><!--

This value is to provide an alterantive location for storing data.--><

add key="StorageLocation" value="~/App_Data/" /><!--

A comma separated list of script names to hard minify. It's case-sensitive. --><

add key="BlogEngine.HardMinify" value="blog.js,widget.js,WebResource.axd" /></

appSettings>

<

system.web><

compilation debug="true"><

assemblies><

add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /><

add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /><

add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" /><

add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" /><

add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /><

add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A" /><

add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089" /></

assemblies></

compilation><

globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto" /><

httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384" /><

machineKey validationKey="D9F7287EFDE8DF4CAFF79011D5308643D8F62AE10CDF30DAB640B7399BF6C57B0269D60A23FBCCC736FC2487ED695512BA95044DE4C58DC02C2BA0C4A266454C" decryptionKey="BDAAF7E00B69BA47B37EEAC328929A06A6647D4C89FED3A7D5C52B12B23680F4" validation="SHA1" decryption="AES" />

<

authentication mode="Forms"><

forms timeout="129600" name=".AUXBLOGENGINE" protection="All" slidingExpiration="true" loginUrl="~/login.aspx" cookieless="UseCookies" /></

authentication>

<

pages enableSessionState="false" enableViewStateMac="true" enableEventValidation="true"><

controls><

add namespace="Controls" tagPrefix="blog" /></

controls></

pages>

<

customErrors mode="Off"><

error statusCode="404" redirect="~/error404.aspx" /></

customErrors>

<

membership defaultProvider="XmlMembershipProvider"><

providers><

clear /><

add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed" /><

add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine" /><

add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine" /></

providers></

membership>

<

roleManager defaultProvider="XmlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES"><

providers><

clear /><

add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider" /><

add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine" /><

add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine" /></

providers></

roleManager>

<

siteMap defaultProvider="PageSiteMap" enabled="true"><

providers><

add name="PageSiteMap" description="The site map provider that reads in the .sitemap XML files." type="BlogEngine.Core.Web.Controls.PageSiteMap, BlogEngine.Core" /><

add name="SecuritySiteMap" description="Used for authenticated users." type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" securityTrimmingEnabled="true" siteMapFile="Web.sitemap" /></

providers></

siteMap>

<

httpModules><

add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" /><

add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core" /><

add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" /><

add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core" /><!--

Remove the default ASP.NET modules we don't need--><

remove name="PassportAuthentication" /><

remove name="Profile" /><

remove name="AnonymousIdentification" /></

httpModules>

<

httpHandlers><

add verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" validate="false" /><

add verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="js.axd" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" validate="false" /><

add verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" validate="false" /><

add verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" validate="false" /><

add verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" validate="false" /></

httpHandlers></

system.web><

system.webServer><

modules><

remove name="Profile" /><

remove name="AnonymousIdentification" /><

add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" preCondition="managedHandler" /><

add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core" preCondition="managedHandler" /><

add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" preCondition="managedHandler" /><

add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core" preCondition="managedHandler" /></

modules><

handlers><

add name="foaf*.axd_*" path="foaf*.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="apml.axd_*" path="apml.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="sioc.axd_*" path="sioc.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="blogml.axd_*" path="blogml.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="opml.axd_*" path="opml.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="rating.axd_*" path="rating.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="js.axd_*" path="js.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="css.axd_*" path="css.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="rsd.axd_*" path="rsd.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="metaweblog.axd_*" path="metaweblog.axd" verb="*" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="opensearch.axd_*" path="opensearch.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="pingback.axd_*" path="pingback.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="trackback.axd_*" path="trackback.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="sitemap.axd_*" path="sitemap.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="syndication.axd_*" path="syndication.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="image.axd_*" path="image.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /><

add name="file.axd_*" path="file.axd" verb="*" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" preCondition="integratedMode,runtimeVersionv2.0" /></

handlers><

validation validateIntegratedModeConfiguration="false" /></

system.webServer></

configuration>

 

Help much appreciated.