This project is read-only.

I'm freakin out... Stuck in an endless loop on start

Topics: Business Logic Layer
May 19, 2010 at 9:34 PM

My installation of BE 1.6 has been customized but I can't think of anything that would cause this. I'm not sure what happended because it was working yesterday and undoing the last couple of lines of code that I added prior to it not working did not fix it. I set break points on the master page and none get hit. I set some more break points in Global.asax and the one on Application_PreRequestHandlerExecute() gets hit. Stepping through the code, the culture setting is set to Auto. When the if block ends instead of exiting the method it restarts and checks for null on the culture setting again. This is driving me crazy. I cannot find the problem. Can someone please, please, please help me?

void Application_PreRequestHandlerExecute(object sender, EventArgs e)
        if (!string.IsNullOrEmpty(Settings.Instance.Culture))
            if (!Settings.Instance.Culture.Equals("Auto"))
                CultureInfo defaultCulture = Utils.GetDefaultCulture();
                Thread.CurrentThread.CurrentUICulture = defaultCulture;
                Thread.CurrentThread.CurrentCulture = defaultCulture;

May 20, 2010 at 12:01 AM

Something else I just noticed... when I go to the property pages of web files folder (BlogEngine.Net) in VS2008 and select Start Options, everything is blank or not selected. And if I try to select say ASP.NET under Debuggers or set a specific page to start I get the following error:

"The operation could not be completed. Element not found."

I downloaded a new copy of BE 1.6  and went to the property pages there and I do not get these errors. So then I took all of my customized BE 1.6 files and overwrote the files from the new copy I downloaded. Same problem, nothing is selected in the in the Start Options and I get an error if I try to set anything.

Anyone have any idea?? This one has me scratching my head.

May 20, 2010 at 7:09 PM

Ok, I still haven't solved the problem but found a clue. I get the following in the output window. I tried enabling breaks when thrown for ThreadAbortException under Debug -->Exceptions but the debugger isn't stopping at the exception. Anyone have any ideas?

A first chance exception of type 'System.Threading.ThreadAbortException' occurred in mscorlib.dll
An exception of type 'System.Threading.ThreadAbortException' occurred in mscorlib.dll but was not handled in user code