Javascript error when not on physical webserver

Topics: ASP.NET 2.0, Business Logic Layer, Controls
May 24, 2010 at 1:49 PM

I am having an issue with the JavaScript not loading and causing the pages to take a long time to load. When I browse the site while RDP’ed onto the server, everything is fine. However, when I browse the site on my network it seems to time out loading the JavaScript and errors out.

Here is the Event Log:

Event Type: Warning
Event Source: ASP.NET 2.0.50727.0
Event Category: Web Event
Event ID: 1309
Date:  5/24/2010
Time:  9:30:26 AM
User:  N/A
Computer: WEBSERVER
Description:
Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 5/24/2010 9:30:26 AM
Event time (UTC): 5/24/2010 1:30:26 PM
Event ID: d5daf5940e254bb18039591f01244a3e
Event sequence: 4
Event occurrence: 1
Event detail code: 0
 
Application information:
    Application domain: /LM/W3SVC/2082238887/Root/mc-1-129191813803845000
    Trust level: Full
    Application Virtual Path: /mc
    Application Path: E:\Website\BlogEngine\Site\mc\
    Machine name: WEB_PROD
 
Process information:
    Process ID: 7608
    Process name: w3wp.exe
    Account name: NT AUTHORITY\NETWORK SERVICE
 
Exception information:
    Exception type: IOException
    Exception message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
 
Request information:
    Request URL: http://blog.aresgrp.com/mc/js.axd?path=http5/24/2010 9:30:26 AMaAn unhandled exception has occurred.fAn unhandled exception has occurred.fblog.aresgrp.comAn unhandled exception has occurred.fmcAn unhandled exception has occurred.fWebResource.axd5/24/2010 9:30:26 AMfd5/24/2010 9:30:26 AMdj246orv_38DeKtGbza6y6A2NT AUTHORITY\NETWORK SERVICEamp5/24/2010 9:30:26 AMbt5/24/2010 9:30:26 AMd633703978583535000
    Request path: /mc/js.axd
    User host address:.X.X.X.X  (Changed for security)
    User: auser (Changed for security)
    Is authenticated: True
    Authentication Type: Forms
    Thread account name: NT AUTHORITY\NETWORK SERVICE
 
Thread information:
    Thread ID: 1
    Thread account name: NT AUTHORITY\NETWORK SERVICE
    Is impersonating: False
    Stack trace:    at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
   at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)

I have setup a website and copied the BlogEngine to individual subdirectories. I then setup each subdirectory as a virtual directory.
Any Help would be appreciated.


 

Coordinator
May 25, 2010 at 2:06 AM

On the Settings tab in the control panel, there's an Advanced Settings section.  Uncheck "Compress WebResource.axd".