DbBlogProvider - Issues

May 24, 2010 at 4:14 PM

I am using MySql for my backend.  I have run into a few issues with because of this.

1. The logging needs to be disabled (unless you are able to update the app_data folder).  The site will still work properly, but the logging won't work.

2.  You have to turn off recaptcha logging.  The commenters will receive an error, but the comment will be posted.  This is due to the call BlogService.LoadFromDataStore.  The Xml provider stores the data as a stream, the DbBlogProviders store the data as a string.  If the logging is enable users will get the "Call back has failed" error message.  If you have custom errors turned off, then they will get the "Unable to cast type System.String to System.Stream".

I have only used the blogengine for a few weeks, but this is what has occurred so far.  I do like the engine as it has made it so easy to create the blogs and avoid spam.

May 25, 2010 at 2:14 AM

Thanks for sharing.  I think some other DB users have reported similar problems with # 2.  It needs to be fixed.

May 25, 2010 at 5:31 AM

For #2. I receive similar error but the comment never gets posted if I am not logged on to BE. From where can we turn off recaptcha logging? I have my site hosted with GoDaddy using SQL Server backend.


May 25, 2010 at 12:15 PM

From the Extensions tab under the Admin menu, click the edit link for Recaptcha.

There's a textbox that says Logging: Maximum successful recaptcha attempts to store (set to 0 to disable logging).  Change that value to 0 to turn off the logging.