Login path doubled

Topics: ASP.NET 2.0
Jul 4, 2010 at 9:16 PM


My Manager is using BlogEngne.net here: http://blog.merlot.aero/. It is hosted at Web Host 4 Life, and in a sub folder called blog.merlot.aero of the hosting root. This folder is a virual directory. We had this working on WH4L before but they have changed their setup and we haven't had login working since copying over.

It works fine but when I go to click on the login link the url is http://blog.merlot.aero/blog.merlot.aero/login.aspx (note the doubled domain name) which doesn't work..

I have tried all sorts of values in the virtual path but either the whole site doesn't work or the url for login is as iti is now. The current value is:  <add key="BlogEngine.VirtualPath" value="~/" />

I didn't set any of this up btw, but have full access. Looks like they are using version (that's the version of BlogEngine.Core.dll in the bin folder).

Any ideas of how to correct this?



Jul 7, 2010 at 3:09 PM


You must have a shared hosting account and have placed BE in a sub-folder which you like setup as an application and pointed to the url blog.merlot.aero.  The problemm is that the blog, while setup as an application is not setup as a site (it is an application under the root directory of your hosting account).  You have a few options:

1.  You can move the blog to the root directory of the hosting account.

2.  You can talk to your hosting provider to see it you can set up multiple sites (as opposed to applications) under your hosting account.

3.  You can move the blog to its own hosting account.

4.  You can change the BE code by removing the ~

The root problem lies with the ~/ notation which is ASP.NET shorthand for the application root.  What is returns is the application root but relative to the root directory of the site. 

Hope that helps.