blogroll # of displayed items how to adjust?

Topics: Controls
Feb 12, 2008 at 2:40 AM
Hey Now,
I'm wondering how to set my blog roll have 0 items displayed. I'm lovin blogEngine.net & kinda new still. I'd like to only have the name of the blog & none of the recent posts of the displayed. I go into settings -> blogroll tab, then when I choose 0 for the drop down it states that there are required fields such as name of title & description. I thank you in advance for any suggestions or comments.
Thank you,
Catto
Feb 12, 2008 at 7:51 AM
Hi Catto,

Blog roll and your recent posts are two separate things (see blog roll as "their" recent posts)

If you don't want -your- recent posts displayed on your blog, you'd need to modify your actual theme file:
/themes/YourTheme/site.master or in /themes/YourTheme/SidePanel.ascx

There you'll find a line looking like this:

<blog:RecentPosts runat="Server" />

Just remove that line and your recent posts won't be displayed anymore.

Does that help?
Mike
Feb 13, 2008 at 2:27 AM
Hey Now MikeyZ & everyone,
What I want to accomplish is to have the Blogroll list the name of the blog & that is it. What I'd rather not have shown is the titles of the posts from the blogs in the blogroll. For example I have a blog '.NET Slave' on my blog roll. Below it shows 3 titles from his recents post 'going to brazil, cash .., & copenhagen geek dinner' I wonder how to remove the 3 titles to the recents posts. The section of code in the master page is

<blog:blogroll ID="Blogroll1" runat="server" />

I thank you for your reply Mikey & I also appreciate any comments from anyone on how to accomplish this.

Thanks,
Catto


MikevZ wrote:
Hi Catto,

Blog roll and your recent posts are two separate things (see blog roll as "their" recent posts)

If you don't want -your- recent posts displayed on your blog, you'd need to modify your actual theme file:
/themes/YourTheme/site.master or in /themes/YourTheme/SidePanel.ascx

There you'll find a line looking like this:

<blog:RecentPosts runat="Server" />

Just remove that line and your recent posts won't be displayed anymore.

Does that help?
Mike

Feb 13, 2008 at 10:30 AM
Hi Catto,

Thank you for clarifying! That error message should appear if you'd click on 'add', but not on 'save'

So your blogroll settings # of displayed items is set to 0, right?

What did you do next? (just to make sure, here's a screenshot what should work)

Cheers
Mike
Feb 16, 2008 at 8:25 AM
Catto, how you're going with your blog(roll)?

Cheers,
Mike
Feb 17, 2008 at 2:38 AM
MikeyZ,
I appreciate all the assistance you are providing. I'm still unable to have the blogroll my blog to have only the name of the blog & not the posts When I go to my blog @ http://blog.chriscatto.com/cattoblog/default.aspx or any other pages I view the blog & the titles of the most recent posts. When I go the URL http://blog.chriscatto.com/cattoblog the blogroll looks good (the way I'm trying to present it) where it only shows the name of the blog. In the control pannel whe;n I change # of displayed items to drop down to zero then click the 'save settings' button it seems like the settings doesn't save. It shows that there are 4 'required' fields which are the 1.title, 2. description 3 website & 4 rss feed. I don't click the 'add' button.
Maybe there is another way I can set the preferences so that the blogroll will only show the title of the blog & not the recent posts?
Thanks again for your assistance.
Catto
Feb 18, 2008 at 2:21 AM
Edited Feb 18, 2008 at 2:27 AM
Here is a screen shot of what I'm seeing. http://www.chriscatto.com/images/blogroll.jpg
thx again
Feb 19, 2008 at 9:16 AM
Hi Catto,

How weird!? The workaround is a bit dirty, but hopefully effective until the BE.NET developers can explain this behavior.

Instead of using your admin interface, you could manually edit the /App_Data/Setting.xml and look for this line:

<blogrollvisibleposts>3</blogrollvisibleposts>

Just replace the number you'll see with 0, save it (and upload back if you're hosting externally)

Would that solve your BlogRoll challenge for now?

Cheers,
Mike
Feb 20, 2008 at 1:53 AM
Hey Now!
I'm still unable to adjust the blogroll # of post visible. http://blog.chriscatto.com/cattoblog/default.aspx. I edited the settings.xml file. I was looking at the master page and see tthe blogroll section. The code is here:
<blog:Blogroll ID="Blogroll1" runat="server" /> . Where is the code that calls the settings file? Do you know any other code to adjust or other files to look at?
Thanks again for your assistance,
Catto
Feb 20, 2008 at 7:14 AM
BE.NET uses settings.xml file basically for everything, but for the most part in the compiled BlogEngine.Core.DLL.

To apply your edited settings.xml file, you'd need to restart the application (pool).
You've got two ways to restart this on your Hostdepartment.com account:

  • Overwrite (re-upload) your .DLL file in the /bin folder
  • Make a small change to your web.config file (more details)

If you don't restart it, your manual edits of .xml files won't be visible.
Feb 20, 2008 at 6:48 PM
Edited Feb 20, 2008 at 6:53 PM
Hey Now Mikey!
Good idea. I tried to do both. I edited the web.config & added a comment. Then I ftp'd the file & tried to refresh the screen but no luck. I also uploaded the blogengine.core.dll file & still there are many tiems dispalyed for each blogroll. If I upload the original blogengine.core.dll file is that good enough? Is entering in a comment i in the web.config a good enough change? If so any other thoughts are appreciated. I also added a new person to my blogroll http://blog.chriscatto.com/cattoblog/ when I'm at that url the blog roll doesn't display posts however when I click home or any other link the blogroll items are displayed again..
Thanks again,
Catto
Feb 20, 2008 at 9:16 PM
Hey Catto,

  • Yes, uploading the original .dll is good enough
  • Yes, any change to the web.config does the trick (adding the comment like you did is a good way)

Just for the record: one of the options should be sufficient, so it's strange neither one worked out :-(

Moreover, the fact your admin interface doesn't allow you to set the # of displayed items to 0 isn't the expected BE.NET behavior either.

Can you confirm you completed the following steps?

  1. Edited the settings.xml file entry manually to <blogrollvisibleposts>0</blogrollvisibleposts>
  2. Uploaded this modified file back to the App_Data folder
  3. Performed one of the application pool restart options?

Thank you for letting us know and adding me to your BlogRoll! ;-)

Mike
Feb 22, 2008 at 1:32 AM
Hey Now Mikey,
Again I appricate your time & effort in assisting me. I'm confirming that I did edit the settings.xml file & upload it to my app_data folder. Then I edited the web.config file & uploaded that too. I noticed the very first time that I went to my blog page the roll looked how I'd prefer it with no posts displayed. But as soon as I clicked any link on the page the posts returned. Check out some shots
1. settings.xml http://www.chriscatto.com/images/BEscreenshotSettingsxml.jpg
2. web.config http://www.chriscatto.com/images/BEscreenshotwebconfig.jpg
3 blogroll nice format http://www.chriscatto.com/images/BEBlogrollzeroitemsdisplayed.jpg
Are you able to set your blog roll to have only the author & title & no posts?
Thx,
Catto
Feb 22, 2008 at 10:14 AM
Hi Catto,

Yes, I'm able to set my blog roll to only show the site/link without any posts.
Simply by using BE.NET's admin interface setting the # to 0.

So again, ít's very strange your admin section prevents you setting that number (showing the required fields error)

Do you think there's some bug in BE.NET in combination with your web hosting company?

Thank you for your nice job on the screenshot documentation. It's my pleasure to discover what's going on with your blogroll. If only we could make some progress. Perhaps you can ping the BE.NET development team to ask for their expert advise?

Cheers Mike