This project is read-only.

Installing on Windows Server 2008 and IIS7

Topics: ASP.NET 2.0
Feb 14, 2008 at 10:15 AM
Edited Feb 14, 2008 at 10:18 AM
Using the Windows Server 2008 RTM I am unable to get BlogEngine.NET to work at all in either Classic or Integrated Managed Pipeline Mode,
I have however gotten it working just fine under Vista and IIS7. (Also not the Windows Server 2008 box is hosing other .NET apps with no problem,
it is also a Domain Controller)

I have tried:
1) Using Integrated Managed Pipeline Mode and migrating the web.config using APPCMD
2) Using Classic Managed Pipeline Mode
3) Giving the Application Pool the Administrator rights
4) Settings the Application to have Full Trust

When running in Classic mode I get the following error:

Configuration Error
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. (C:\Users\Administrator\Desktop\Test\BlogEngine\web.config line 83)

Source Error:

Line 81:
Line 82: <httpModules>
Line 83: <add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" />
Line 84: <add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core" />
Line 85: <add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core" />

Source File: C:\Users\Administrator\Desktop\Test\BlogEngine\web.config Line: 83

The line Line 83: <add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core" />
gets highlighted, from the looks of it it can't find the assembly or something, I'm not sure what.

Has anyone successfully gotten BlogEngine.NET running on Windows Server 2008 RTM and IIS7?

Does anyone have any ideas?

Thanks in advance,
Feb 14, 2008 at 11:38 AM
It is running in Visual Studio (with ASP Web Server)?
Do you have all ASP.NET versions, specially 2.0 ?
Why error msgs are from C:\... (file !!!), It need to be a virtual directory in your IIS installation
Take a look to thats applications who are running
Let me know what happen
Feb 14, 2008 at 5:51 PM
To answer your questions:

1) I haven't tried running using Visual Studio yet, I'm going to install it now.
2) It is running ASP.NET specifically
3) I don't think it has to be in a Virtual Directory does it? I configured it the same way
as I have it under Vista which works.

The only message in the logs is:

2008-02-14 17:48:23 ::1 GET /BlogEngine/default.aspx - 82 - ::1 Mozilla/4.0(compatible;MSIE7.0;WindowsNT6.0;WOW64;SLCC1;.NETCLR2.0.50727;.NETCLR3.0.04506) 500 0 0
Feb 14, 2008 at 11:20 PM
Edited Feb 14, 2008 at 11:24 PM
I see that you are using publishing version of BlogEngine, its work in a hosting environmet and I do not know about Vista and IIS, I think that is the same in XP or WS2003.

Also with IIS, you need to create a virtual directory (local site) pointing to a real directory in your disk, then you need to give write permission to App_Data directory

How do you access to the site. In my local installation I use (http://icaro/BlogEngine) icaro is the name of my pc wich have WS2003R2SP2 and IIS 6.0; BlogEngine is a virtual directory who points to D:\BlogEngine\BlogEngine.NET (that is the real directory where i have the ASP site)

Recalls a server operating system is more demanding