RSS feed marks old items as new

Feb 14, 2008 at 1:50 PM
This has been very sporadic, but our RSS feed keeps posting old items as new ones, so our subscribers see old updates repeatedly. It's unpredictable which old one will get reposted, but it is happening very consistently. Everything else works fine... any thoughts on what could be causing this?
Coordinator
Feb 14, 2008 at 2:07 PM
I'm getting this too, I noticed that duplicate feed has "nospam@nospam" as part of the author name. It might have something to do with author of the post making a comment. What version of BE are you running and when did you noticed it first time?
Coordinator
Feb 14, 2008 at 2:07 PM
Edited Feb 14, 2008 at 2:09 PM
Looks like codeplex dose it too - some of the comments sporadically duplicated, like this one :)
Feb 14, 2008 at 2:13 PM

rtur wrote:
Looks like codeplex dose it too - some of the comments sporadically duplicated, like this one :)


I'm running 1.3, and even updated to get the latest bug fixes... and it still does it. I just installed BE a few months ago, right after 1.3 came out, so this has been a problem from the start.
Feb 14, 2008 at 2:16 PM
Thanks rtur. Some of the posts on my blog are missing a valid email address for the author, so I'll see if that helps any. Anyway, I'm running 1.3 (I just started using BE two months ago) and this has been an intermittent problem since the start.
Feb 19, 2008 at 8:09 AM
Experiencing the same here:

1. Occassional duplicated posts in the feed (in my Outlook RSS that is, not in Feedburner)
2. No.spam@no.spam addition since upgrading to v1.3

To 'fix' the second point, I'd to modify the source code for BlogEngine.Core.DLL which added that part.

FYI: the source code generating this nospam is in \Core\SyndicationGenerator.CS (line #531)

writer.WriteElementString("author", BlogSettings.Instance.Email.Replace("@", ".nospam@nospam.") + " (" + publishable.Author + ")");

I've replaced that with just:

writer.WriteElementString("author", publishable.Author);

Hope this helps.
Apr 26, 2008 at 6:57 PM
I have the same issue. Old post appears as new in my feed even in feedburner. I run the last version of blogengine.... Someone can help?
May 4, 2008 at 8:04 AM
I had the same problems with RSS. Please help, my readers are nervous!
http://podlipensky.com/
Sep 5, 2008 at 3:43 AM
Has anyone found a solution to this problem? 
Sep 5, 2008 at 11:35 AM

We ended up writing our own RSS generator to go alongside blog engine... I have no idea what the problem was

Andrew


From: dcayon [mailto:notifications@codeplex.com]
Sent: Thursday, September 04, 2008 11:44 PM
To: Andrew Mahr
Subject: Re: RSS feed marks old items as new [blogengine:22140]

From: dcayon

Has anyone found a solution to this problem?

Read the full discussion online.

To add a post to this discussion, reply to this email (blogengine@discussions.codeplex.com)

To start a new discussion for this project, email blogengine@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Sep 22, 2008 at 1:38 PM
I get this too.

What is wrong with this thing?  Any idea on how to fix it?
Sep 22, 2008 at 1:44 PM
due to the amount of users that are having problems with this, I created a Workitem.  Please vote on it so it gets pushed up in the "ToDo" list.

Can be found at:

http://www.codeplex.com/blogengine/WorkItem/View.aspx?WorkItemId=7648