Runtime error on installation

Topics: ASP.NET 2.0
Jul 27, 2010 at 4:26 PM
Edited Jul 27, 2010 at 7:39 PM

Hello, first off I'm sorry if this question is elementary, this is my first time working with any .Net files.

I followed the installation instructions and unzipped the files. I then renamed the folder to "blog" and uploaded via FTP to my hosting account.

In the instructions it says to identify the folder as a .Net application. The installation video only shows how to do this on a local machine with IIS, but I'm trying to put this on my hosted account so it says to do it through the hosting control panel. I am using Concentric WinBasic hosting and did not see where to do this. Their help said that my hosting account is already set up for .Net 2.0 so it should work and I don't have to do anything. Is this right?

After uploading the files I attempted to view the /blog/default.aspx page and got this error: _________________________________________________________________________________________________________________________________

Server Error in '/' Application. Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off". <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="Off"/> </system.web> </configuration> Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL. <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web> </configuration> _________________________________________________________________________________________________________________________________

 

Not sure what to do here, as I mentioned I'm very new to .Net. Any help is appreaicated!

Coordinator
Jul 28, 2010 at 4:28 AM

In the root folder is a file named "web.config".  In that file is a <customErrors> tag.  If you change that tag to the following, you should then get a real error message, rather than the generic one you're seeing now:

<customErrors mode="Off">

The tag above is case sensitive.  Basically the error message you're seeing now is hinting for you to make this change.

Jul 28, 2010 at 3:40 PM
Edited Jul 28, 2010 at 3:42 PM
Thanks for your help! So I changed this: <customErrors mode="RemoteOnly" defaultRedirect="~/error404.aspx"> <error statusCode="404" redirect="~/error404.aspx"/> </customErrors> To this: <customErrors mode="Off"></customErrors> And now the error message says this: Server Error in '/' Application. Configuration Error Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. Source Error: Line 7: </configSections> Line 8: <BlogEngine> Line 9: <blogProvider defaultProvider="XmlBlogProvider"> Line 10: <providers> Line 11: <add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/> So it still needs me to set the blog folder as an application? There's not an option to do that with my hosting provider, and their help said it wouldn't be necessary. Where they wrong? I haven't really worked with IIS so I'm not sure how to set it up through that. Any further help you could provide is greatly appreciated.