Web.Config Error (Handler Not Yet Determined)

Jul 31, 2010 at 11:48 AM


I'm new to IIS 7, I wanted to experiment with blogEngine with my local site however, I'm having problems installing the application. I used the instructions from the video guide as closely as possible since the guide was for an older version of IIS and windows I had improvise using some other guides :

-Downloaded the Zip file and extracted it

-Removed the ReadOnly attribute of teh directory and moved it to c:\inetpub\wwwroot

-Went into IIS and Right Clicked the blogEngine and selected Convert to Application (the Add Application dialog box appeared). I did minimal changes here, if anything.

-Then I went to the AppData directory and changed it's permission. Since ASP.NET user was not available, I looked up the internet and it said that with IIS7 the equilant user is NETWORK SERVICES (?), so I gave NETWORK SERVICES modify permission.

I then navigated to localhost\blogEngine and I get the following 500.19 Internal Server Error:

ModuleIIS Web Core
HandlerNot yet determined
Error Code0x80070021
Config ErrorThis configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File\\?\C:\inetpub\wwwroot\BlogEngine\web.config
Requested URLhttp://localhost:80/blogengine
Physical PathC:\inetpub\wwwroot\BlogEngine
Logon MethodNot yet determined
Logon UserNot yet determined
125: </modules>
  126: <handlers accessPolicy="Read, Write, Script, Execute">
  127: <add name="FileHandler" verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" resourceType="Unspecified" requireAccess="Script" preCondition="integratedMode"/>
 Now, I haven't modified the web.config at all, and the guide doesn't mentione anything about modifying this file. I'm currently running Windows 7 which has IIS7, and running MySQL (however, I understand that BE writes to XML)
Please help with this. 




Jul 31, 2010 at 1:36 PM

I've managed to resolve this. For anyone who is interested :

1. Change the settings in C:\Windows\System32\inetsrv\config\applicationHost.config and changed the attributes to Allow for <Section Name=handlers and also <Section name=Module