Metaweblog, Blogengine.net, Digg

Feb 19, 2008 at 4:22 PM
I am trying to setup my blog with Digg. In the field URL for XML-RPC of Blog, I am putting http://mydomain.com/blog/metaweblog.axd. In the field URL of Blog, I am putting http://mydomain.com/blog/. For some reason I am getting this error. How do I locate the metaweblog.axd file. Is there anyone else that's been able to get this to work.
Feb 19, 2008 at 4:53 PM
Edited Feb 19, 2008 at 4:54 PM
The metaweblog.axd is generated by an httphandler. You just have to use the complete url with the metaweblog.axd.

You can see the inheritance at http://www.romanclarkson.us/BlogEngineHTMLDoc/html/585eb16c-2f2b-d3b0-7abc-965b7a1e2e7c.htm
Feb 19, 2008 at 7:20 PM


rclarkson wrote:
The metaweblog.axd is generated by an httphandler. You just have to use the complete url with the metaweblog.axd.

You can see the inheritance at http://www.romanclarkson.us/BlogEngineHTMLDoc/html/585eb16c-2f2b-d3b0-7abc-965b7a1e2e7c.htm


Sorry to be a pain - I am new at this. Can you give me an example. Is http://mydomain.com/blog/metaweblog.axd wrong??
Feb 20, 2008 at 2:01 AM
I don't think you need to enter anything about the metaweblog.axd. Just enter the primary address http://mydomain.com/blog and you should be fine.
Feb 20, 2008 at 3:00 AM
Alternately, try http://mydomain.com/metaweblog.axd


dscoduc wrote:
I don't think you need to enter anything about the metaweblog.axd. Just enter the primary address http://mydomain.com/blog and you should be fine.

Feb 20, 2008 at 1:53 PM
I just tried Digg and I could not get it to work either. I came across Al's website with an entry about Digg not working. Based on other blogs it appears, at the time of their publication, that Digg is not implementing some sort of metaweblog feature dealing with mulitple authors. Don't know any more than that.
Aug 8, 2008 at 6:00 PM
Any update on this.  I've tried several variation to try to get my blog in Digg, but have failed.  There doesn't seem to be much chatter about this.

Help?
Aug 8, 2008 at 6:08 PM
Hitting this:  http://www.waynejohn.com/metaweblog.axd

Results in this:
Invalid XMLRPC Request. (StartIndex cannot be less than zero. Parameter name: startIndex)

Any love out there?  Am I missing something here, or is this what I should expect back?

BTW, I'm using Live Writer without issue, only now that I tried to add this to Digg have I noticed this.

Cheers!
Aug 12, 2008 at 8:26 PM
Ping!  Can anyone answer this?
Sep 17, 2008 at 9:26 PM
Well, this is what happens when you stray off the beaten path.  No support, no love, just a big FU do it yourself.

Is there ANY BE user that has configured their blog with Digg???
Sep 17, 2008 at 11:36 PM
You aren't being ignored by me.  I tried again.  I'm not sure what is going on.  I tried a few more things again and it did not work. Have you found anything specific from Digg that says this is what we are doing when we enter in the xml-rpc information?  Regarding the FU.  That's open source.
Sep 28, 2008 at 3:12 AM
Thanks for responding rclarkson, I didn't mean any offense to you by the way.  I'm just quite frustrated that there isn't more activity around this app.  It's a great tool, just wish more people were active with it.

As for the Digg, I've given up on that until I get my head more around the core application.  At some point, I'll be able to dig in to this issue a bit more. 


Sep 28, 2008 at 9:53 AM
Wayne, I don't know if its of any help, but the developers all seem to have gone on holidays for the last few weeks.
Sep 28, 2008 at 5:42 PM
Holiday?!?!?!  They get breaks?  ;)
Feb 25, 2009 at 11:02 PM
Hey, I'm having exactly the same problem with Digg.  I specify the full url to the metaweblog.axd and Digg cannot connect.
I've tried just about everything and I'm running out of hair!