Two domains single database

Sep 3, 2010 at 4:37 PM

Hi,

I am new to blogengine and I have created two domains in godaddy. I have configured one SQL server database. For the first domain, I have copied blogengine in the root directory and works fine. For the second domain - I have a directory but this gives a 500 internal server error. Even if I don't use the database & use only xmldbprovider to store I get the same error. Please tell me how to configure two domains with blogengine.

Thanks 

Shankar

Sep 4, 2010 at 2:10 AM
Edited Sep 4, 2010 at 2:11 AM

Shankar,

This sounds like a server configuration.  I run several TLD blogs useing godaddy with no issuse.

please check the following

  1. the the domain  not on the root "root/mysite.com is set up to run as it's own applicatoin
  2. and make sure you set the following in your config file <add key="BlogEngine.VirtualPath" value="~/"/>
    1. when the blog is running in a TLD application then your virtual path would be "~/"
    2. if not running in a TLD it should follow the path of the folder structure
    3. e.g. "root/mysite/blogApp" then virtual path would be "~/blogApp"

Hope it helps.

Craig

Sep 4, 2010 at 1:28 PM

Craig,

Thanks for the help. I have my first website on the root (www.one.com). The second website is configured in a directory inside the root (www.two.com - path is /two). I have copied the blogengine in the root folder as well as the 'two' folder. I have set the <location path="." inheritInChildApplications="false"> for the system.web tab in the root directory web.config file.

In the child directory I have tried both options for the virtual path in the appSettings (<add key="BlogEngine.VirtualPath" value="~/"/> and <add key="BlogEngine.VirtualPath" value="~/two/"/> ). But both seems not to solve the issue.

If I do not add the following in config - then I get blog:PostCalendar not found. But if I add the following, I always get the 500 internal server error. 

<pages enableSessionState="false" enableViewStateMac="true" enableEventValidation="true"> <controls> <add namespace="Controls" tagPrefix="blog"/> </controls> </pages>

Both the websites are as their own application. But still not able to find the correct configuration.

Shankar.