This project is read-only.

reCaptcha has permission issues

Oct 21, 2010 at 6:29 PM

I try to enable reCaptcha and I get this error

Changes will not be applied: Access to the path 'C:\Inetpub\wwwroot\bloglinda\Web.Config' is denied.


At first I thought it might be permissions for the ASP.NET account or the NETWORK SERVICES account but I went in and put those accouns on the root blog folder and set permissions for write and still nothing happens. Still get the same error.

Oct 21, 2010 at 6:35 PM

OK so I just went in and gave both accounts "Full Control" which I really don't want to do but it does work now. Anyone know which permissions are actually required. This is running on IIS 6 Windows 2003 Server. I set the permissions in Windows Explorer folders properties.

Oct 21, 2010 at 7:14 PM

Write permissions are needed for the entire App_Data folder.

The web.config file in the root is the only exception where when you enable/disable extensions, BE makes a small update to the web.config file (just changing the timestamp on the file) to make the blog restart.  This is because an extension's enabled status is only picked up when the blog starts.

So if you want to keep things locked down, you could have Write permissions turned on for the entire App_Data folder, plus the web.config file (just this file).

Oct 21, 2010 at 7:25 PM

OK Thanks, I'll give that a try.

I appreciate your response.