error during blogengine.net installation

Topics: ASP.NET 2.0
Oct 21, 2010 at 7:22 PM

  Problem:-

Server Error in '/' Application.

Configuration Error

 

 

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'BlogEngine.Core' or one of its dependencies. The system cannot find the file specified.

Source Error:

Line 66: 			<providers>
Line 67: 				<clear/>
Line 68: 				<add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider"/>
Line 69: 				<add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>
Line 70: 				<add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>


Source File: E:\kunden\homepages\39\d234979030\web.config    Line: 68

Assembly Load Trace: The following information can be helpful to determine why the assembly 'BlogEngine.Core' could not be loaded.

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

Environment:-  1and1 Host,  IIS 6.0

Folder structure:-  /  root

                          under root BlogEngine  - this folder is setup as application folder

                           root folder has web.config file ( I moved the web.config file from BogEngine to the root folder other wise 1and1 host is not detecting the config file) and default.aspx file. 

blogs.domainname.com destinations is set to the root folder. default.aspx has the following code

<%EnableSessionState=False

host = Request.ServerVariables("HTTP_HOST")

if host = "blogs.domainname.com" then
response.redirect("http://domainname.com/BlogEngine/default.aspx")

end if
%>

                  I provided the write access to APP_DATA folder.

I need help resolving this error.

 

Copy of my config File:-

I removed the <system.webserver> </system.webServer> tag from the config file because of IIS6.0

My changes to config file are in red



        Thanks

Amal

<?xml version="1.0"?>

<configuration>

<configSections>

<sectionGroup name="BlogEngine">

<section name="blogProvider" requirePermission="false" type="BlogEngine.Core.Providers.BlogProviderSection, BlogEngine.Core" allowDefinition="MachineToApplication" restartOnExternalChanges="true"/>

</sectionGroup>

</configSections>

<BlogEngine>

<blogProvider defaultProvider="XmlBlogProvider">

<providers>

<add name="XmlBlogProvider" type="BlogEngine.Core.Providers.XmlBlogProvider, BlogEngine.Core"/>

<add name="DbBlogProvider" type="BlogEngine.Core.Providers.DbBlogProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>

</providers>

</blogProvider>

</BlogEngine>

<connectionStrings>

<clear/>

<add name="BlogEngine" connectionString="Data Source=MySQLServer;User ID=user;Password=password;persist security info=False;initial catalog=BlogEngine;" providerName="System.Data.SqlClient"/>

</connectionStrings>

<appSettings>

<add key="BlogEngine.FileExtension" value=".aspx"/>

<!-- You can e.g. use "~/blog/" if BlogEngine.NET is not located in the root of the application -->

<add key="BlogEngine.VirtualPath" value="~/"/>

<!-- The regex used to identify mobile devices so a different theme can be shown -->

<add key="BlogEngine.MobileDevices" value="(nokia|sonyericsson|blackberry|samsung|sec\-|windows ce|motorola|mot\-|up.b|midp\-)"/>

<!-- The name of the role with administrator permissions -->

<add key="BlogEngine.AdminRole" value="Administrators"/>

<!--This value is to provide an alterantive location for storing data.-->

<add key="StorageLocation" value="~/App_Data/"/>

<!--A comma separated list of script names to hard minify. It's case-sensitive. -->

<add key="BlogEngine.HardMinify" value="blog.js,widget.js,WebResource.axd"/>

</appSettings>

<system.web>

<compilation debug="false">

<assemblies>

<add assembly="System.Management, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

<add assembly="System.Configuration, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

<add assembly="System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

<add assembly="System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

<add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

<add assembly="System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

<add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

</assemblies>

</compilation>

<globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto"/>

<httpRuntime enableVersionHeader="false" useFullyQualifiedRedirectUrl="true" maxRequestLength="16384" executionTimeout="3600" requestLengthDiskThreshold="16384"/>

<machineKey validationKey="D9F7287EFDE8DF4CAFF79011D5308643D8F62AE10CDF30DAB640B7399BF6C57B0269D60A23FBCCC736FC2487ED695512BA95044DE4C58DC02C2BA0C4A266454C" decryptionKey="BDAAF7E00B69BA47B37EEAC328929A06A6647D4C89FED3A7D5C52B12B23680F4" validation="SHA1" decryption="AES"/>

<authentication mode="Forms">

<forms timeout="129600" name=".AUXBLOGENGINE" protection="All" slidingExpiration="true" loginUrl="~/login.aspx" cookieless="UseCookies"/>

</authentication>

<pages enableSessionState="false" enableViewStateMac="true" enableEventValidation="true">

<controls>

<add namespace="Controls" tagPrefix="blog"/>

</controls>

</pages>

<customErrors mode="Off"/>

<membership defaultProvider="XmlMembershipProvider">

<providers>

<clear/>

<add name="XmlMembershipProvider" type="BlogEngine.Core.Providers.XmlMembershipProvider, BlogEngine.Core" description="XML membership provider" passwordFormat="Hashed"/>

<add name="SqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>

<add name="DbMembershipProvider" type="BlogEngine.Core.Providers.DbMembershipProvider, BlogEngine.Core" passwordFormat="Hashed" connectionStringName="BlogEngine"/>

</providers>

</membership>

<roleManager defaultProvider="XmlRoleProvider" enabled="true" cacheRolesInCookie="true" cookieName=".BLOGENGINEROLES">

<providers>

<clear/>

<add name="XmlRoleProvider" type="BlogEngine.Core.Providers.XmlRoleProvider, BlogEngine.Core" description="XML role provider"/>

<add name="SqlRoleProvider" type="System.Web.Security.SqlRoleProvider" connectionStringName="BlogEngine" applicationName="BlogEngine"/>

<add name="DbRoleProvider" type="BlogEngine.Core.Providers.DbRoleProvider, BlogEngine.Core" connectionStringName="BlogEngine"/>

<remove name="DbRoleProvider"/>

</providers>

</roleManager>

<siteMap defaultProvider="PageSiteMap" enabled="true">

<providers>

<add name="PageSiteMap" description="The site map provider that reads in the .sitemap XML files." type="BlogEngine.Core.Web.Controls.PageSiteMap, BlogEngine.Core"/>

<add name="SecuritySiteMap" description="Used for authenticated users." type="System.Web.XmlSiteMapProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" securityTrimmingEnabled="true" siteMapFile="Web.sitemap"/>

</providers>

</siteMap>

<httpModules>

<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>

<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>

<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>

<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core"/>

<!--Remove the default ASP.NET modules we don't need-->

<remove name="PassportAuthentication"/>

<remove name="Profile"/>

<remove name="AnonymousIdentification"/>

<remove name="WwwSubDomainModule"/>

<remove name="UrlRewrite"/>

<remove name="CompressionModule"/>

<remove name="ReferrerModule"/>

</httpModules>

<httpHandlers>

<add verb="*" path="file.axd" type="BlogEngine.Core.Web.HttpHandlers.FileHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="image.axd" type="BlogEngine.Core.Web.HttpHandlers.ImageHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="syndication.axd" type="BlogEngine.Core.Web.HttpHandlers.SyndicationHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="sitemap.axd" type="BlogEngine.Core.Web.HttpHandlers.SiteMap, BlogEngine.Core" validate="false"/>

<add verb="*" path="trackback.axd" type="BlogEngine.Core.Web.HttpHandlers.TrackbackHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="pingback.axd" type="BlogEngine.Core.Web.HttpHandlers.PingbackHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="opensearch.axd" type="BlogEngine.Core.Web.HttpHandlers.OpenSearchHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="metaweblog.axd" type="BlogEngine.Core.API.MetaWeblog.MetaWeblogHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="rsd.axd" type="BlogEngine.Core.Web.HttpHandlers.RsdHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="css.axd" type="BlogEngine.Core.Web.HttpHandlers.CssHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="js.axd" type="BlogEngine.Core.Web.HttpHandlers.JavaScriptHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="rating.axd" type="BlogEngine.Core.Web.HttpHandlers.RatingHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="opml.axd" type="BlogEngine.Core.Web.HttpHandlers.OpmlHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="blogml.axd" type="BlogEngine.Core.Web.HttpHandlers.BlogMLExportHandler, BlogEngine.Core" validate="false"/>

<add verb="*" path="sioc.axd" type="BlogEngine.Core.Web.HttpHandlers.Sioc, BlogEngine.Core" validate="false"/>

<add verb="*" path="apml.axd" type="BlogEngine.Core.Web.HttpHandlers.Apml, BlogEngine.Core" validate="false"/>

<add verb="*" path="foaf*.axd" type="BlogEngine.Core.Web.HttpHandlers.Foaf, BlogEngine.Core" validate="false"/>

</httpHandlers>

</system.web>

</configuration>

Nov 14, 2010 at 12:04 PM

I have the same issue, I'm also with 1&1. Did you resolve it yet?

Nov 15, 2010 at 1:25 AM
No, I did not.

Thanks
Amal


From: [email removed]
To: [email removed]
Date: Sun, 14 Nov 2010 04:04:41 -0800
Subject: Re: error during blogengine.net installation [blogengine:231855]

From: nadjibus
I have the same issue, I'm also with 1&1. Did you resolve it yet?
Read the full discussion online.
To add a post to this discussion, reply to this email (blogengine@discussions.codeplex.com)
To start a new discussion for this project, email blogengine@discussions.codeplex.com
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com