Problem with latest release from HG

Topics: ASP.NET 2.0, Business Logic Layer
Nov 4, 2010 at 2:41 PM

First I should say that I am not much of a web developer...

At any rate I had a blog with BlogEngine 1.4.1

I decided to upgrade to the latest version from Mercurial (from 4 November 2010).
I did run the Sql scripts to update my  SqlServer from 1.4 => 1.4.5 => 1.5 => 1.6 => 2.0 

I deleted all files and folder except App_Data/files

I uploaded a precompiled version (with no update support), and tweaked the web config to use the Sql Web.config with the right connection string

The web site started, looked as it did before (with a few exception) and I was able to login with admin / admin

I tried to create a user and got this error (custom error off)

==

Server Error in '/codeblog/admin' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 

Parser Error Message: Could not load file or assembly 'BlogEngine.Core' or one of its dependencies. The system cannot find the file specified. (\\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config line 111)

Source Error: 

Line 109:		</siteMap>
Line 110:		<httpModules>
Line 111:			<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>
Line 112:			<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>
Line 113:			<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>


Source File: \\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config    Line: 111 



==

 

Also loading the first page is so slow..... I thought that using SqlServer (instead of VistaDB) and precompiled my blog will have speed up things, but instead they slow down quite a bit! Any clues as to why?

Strangely enough I can access the user administration screen without trouble when I run it locally!

Nov 4, 2010 at 3:03 PM

Out of curiosity I deactivated this module, but then I get an error on the next line!

==

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'BlogEngine.Core' or one of its dependencies. The system cannot find the file specified. (\\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config line 112)

Source Error:

Line 110:		<httpModules>
Line 111:			<!--<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>-->
Line 112:			<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>
Line 113:			<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>
Line 114:			<add name="ReferrerModule" type="BlogEngine.Core.Web.HttpModules.ReferrerModule, BlogEngine.Core"/>


Source File: \\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config    Line: 112
==

 

Nov 4, 2010 at 4:03 PM

I downgraded to the official 1.6 version (included reverted the change in the DB).

And I got exactly the same error! :(
==
 Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Could not load file or assembly 'BlogEngine.Core' or one of its dependencies. The system cannot find the file specified. (\\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config line 83)

Source Error:

Line 81: 		</siteMap>
Line 82: 		<httpModules>
Line 83: 			<add name="WwwSubDomainModule" type="BlogEngine.Core.Web.HttpModules.WwwSubDomainModule, BlogEngine.Core"/>
Line 84: 			<add name="UrlRewrite" type="BlogEngine.Core.Web.HttpModules.UrlRewrite, BlogEngine.Core"/>
Line 85: 			<add name="CompressionModule" type="BlogEngine.Core.Web.HttpModules.CompressionModule, BlogEngine.Core"/>

Source File: \\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config    Line: 83


Version Information: Microsoft .NET Framework Version:2.0.50727.3615; ASP.NET Version:2.0.50727.3053

<!-- [ConfigurationErrorsException]: Could not load file or assembly 'BlogEngine.Core' or one of its dependencies. The system cannot find the file specified. (\\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config line 83) (\\boswinfs04\home\users\web\b1659\whl.lloydd\codeblog\web.config line 83) at System.Web.Configuration.HttpModuleAction.get_Entry() at System.Web.Configuration.HttpModulesSection.CreateModules() at System.Web.HttpApplication.InitModules() at System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) at System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) at System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) --><!-- This error page might contain sensitive information because ASP.NET is configured to show verbose error messages using <customErrors mode="Off"/>. Consider using <customErrors mode="On"/> or <customErrors mode="RemoteOnly"/> in production environments.-->
==

Server Error in '/codeblog/admin/Pages' Application.

Configuration Error

 



BTW, the blog start much faster with the official 1.6 release! :)
But I still can't admin my users :(

Coordinator
Nov 4, 2010 at 6:13 PM

If you use the code from Mercurial, did you compile the BE core project ?  You should have a BlogEngine.Core.dll file in your /BIN directory.

Looking at the error messages, it sounds like that DLL isn't there.

Nov 4, 2010 at 10:43 PM

Yes, the DLL is in there! (same problem with the released 1.6)(i.e. with the DLL already in the bin folder and no source code)

I wonder.. for desktop application I can specify if my .NET aplication target 32/64 bit or not. But some googling mentioned it could be just that...

Any idea where is this settings for web project? would it be relevant?

Nov 4, 2010 at 10:58 PM

I also opened a support ticket with webhost4life.com, will see if they can help!

Coordinator
Nov 5, 2010 at 2:24 AM

In the past, some people have reported problems with getting a precompiled BE site to work.  By precompiled, I mean when you have many small DLL files in your BIN directory.

The typical way to deploy BE is by just copying the web files to the web server, without precompiling.  In total, there is 1 DLL (BlogEngine.Core.dll) in the BIN directory.

I'm not sure if that's the issue here, but it's one possibility that has come to mind, based on what I've read here in this thread.

Nov 5, 2010 at 2:36 AM

Mm.. thanks for the tip! I have to try!

 

One "problem" with that though, is that I precompiled with the hope of getting the best performance out of BlogEngine! And the first display of a page is usually quite slow...

Will it help performance or not to precompile the web site?

 

Coordinator
Nov 5, 2010 at 3:12 AM

Since I never precompile, I can't say for sure.  If you have a lot of data (i.e. posts), the first load can take a few seconds as BE reads all data in and caches it in memory.  I'm guessing that the reading in of this data is more time consuming than the compilation of the files in the App_Code folder.

After the first hit to the site, once all the data is cached, and code has been compiled, everything goes very fast.

Nov 6, 2010 at 6:40 AM

I asked my web host and they said they were able to reproduce the issue and are looking into it, yeah! :)