compression module error IIS 7.5 / server 2008 std

Topics: ASP.NET 2.0
Nov 7, 2010 at 9:55 PM

Hi All: I moved an existing site running BE 1.6.0.1 from server 2008 to server 2008R2.

When someone tries to post, they're getting 500 error, which in FREQ says:

MODULE_SET_RESPONSE_ERROR_STATUS 

ModuleName CompressionModule 

Notification 64 

HttpStatus 500 

HttpReason Internal Server Error 

HttpSubStatus 0 

ErrorCode 0 

ConfigExceptionInfo  Notification PRE_EXECUTE_REQUEST_HANDLER ErrorCode The operation completed successfully. (0x0) 

I was able to log in and check the settings, and I noticed that "makes the pages load faster" was checked. Thinking that might have something to do with it, I tried to uncheck it and save the settings, but I get the same 500 error when I try to save...so something in the postback seems to be awry...am I missing something obvious in the settings?

The parent website is running .net 4 in integrated mode, and BE is running as it's own application within that pool.

Coordinator
Nov 7, 2010 at 10:20 PM

My guess is that the COMPRESSION you see in the error details is not BE's compression module, but the compression module that is included with IIS 7.

If you open up IIS 7, and go to your site, in the IIS section is an icon for "compression".  You could try changing the options there.

Nov 10, 2010 at 5:50 PM

Thanks Ben: I'm not sure what the problem is. I don't have "dynamic compression" enabled on the webserver, so it's grayed out in IIS manager. I did have "static compression" enabled on both the parent website and BE's application. I disabled it on both and it makes no difference.

Something else is weird...If I view the "settings" in the admin area, "Makes the pages load faster (recommended)." is checked, but in the database table for be_Settings, "enablehttpcompression" is set to "false". I even changed it to false in the XML settings in App_data (which the website should not be using), but it's still showing as checked. "save settings" throws the 500 error. Not sure if I'm seeing a locally cached page which might explain that.

It seems like any request involving a postback from the admin area is throwing the 500 error, but anything in the main BE website is fine. For example, I can log in and log out from the main BE pages, and even delete comments, but if I navigate to the admin area and click "logout" I get the error.

If I navigate to "referrers" in the admin area and click the checkbox next to "enable referrer tracking", the page posts back successfully and the setting is changed. Not sure what's different in that postback vs. the logout button, except I see the logout button is calling the "javascript:__dopostback" method.

As a final test I'll try clearing my cache and deleting cookies to see if that makes any difference.

Nov 10, 2010 at 7:51 PM

update: clearing cache/cookies/etc., didn't help

Coordinator
Nov 10, 2010 at 8:04 PM

In the Advanced Settings, I would uncheck these items to see if there's a difference (some you have maybe already unchecked):

  • Enable HTTP compression
  • Trim stylesheets
  • Compress WebResource.axd

Another thing to check ... if your application pool for BE is set to run ASP.NET 4.0 (as opposed to ASP.NET 2.0) and you haven't already, you will want to update the <httpRuntime> tag in the web.config file as noted here.

Nov 10, 2010 at 8:51 PM
BenAmada wrote:

In the Advanced Settings, I would uncheck these items to see if there's a difference (some you have maybe already unchecked):

  • Enable HTTP compression
  • Trim stylesheets
  • Compress WebResource.axd

Another thing to check ... if your application pool for BE is set to run ASP.NET 4.0 (as opposed to ASP.NET 2.0) and you haven't already, you will want to update the <httpRuntime> tag in the web.config file as noted here.

Hi Ben: The AppPool is set to 4.0 integrated, and all three of those settings were still checked. I added 

requestValidationMode="2.0"

to the httpruntime tag in BE's web.config, logged in again, but when I unchecked "enable http compression" and tried to save settings, I got the "500" error again.

So, just for fun, I hit the "back" button, un-checked all three checkboxes, and when I hit "save settings" this time it worked! But why it worked seems very mysterious? I don't know if the first time I saved the compression setting was disabled after the 500 error was returned...very weird.

Just tried a test post, and that's working as well, so it seems like it was one of those settings...probably "compress webresource.axd" that was the problem.

Thanks for pointing me to the correct settings!