How to disable ajax in comments

Topics: Controls
Nov 9, 2010 at 1:11 PM

Ajax does not work in some browser, especially in mobile browser.

I want to disable ajax in comments and only use traditional post back.

how can I achieve this?

 

Your reply will be approciated.

Nov 11, 2010 at 4:39 AM

Is there anyone know this?

Nov 11, 2010 at 6:55 AM
Edited Nov 11, 2010 at 6:57 AM

I'm not sure what you mean by the comment system using ajax.  Version 1.6 uses postbacks to submit comments.  There's quite a bit of DHTML in there, but I didn't really see any XmlHTTP, although its possible I missed a call somewhere...

EDIT: the recapcha uses XmlHTTP I think (can't remember now), and perhaps some spam validators do too... but you can disable those through settings.

Coordinator
Nov 11, 2010 at 5:28 PM

Actually, the comment system uses AJAX only -- regardless of any spam validators that may be turned on.

Technically, it's using the "callback" system in ASP.NET -- which is AJAX based.  The "addComment" JS function in blog.js is used for all comment submissions.  This function makes the AJAX based "callback".

Nov 11, 2010 at 6:20 PM

Ah, ok.  I just saw the Webform_doPostback and did't realize that it uses ajax.  In that case, it would be a pretty significant rewrite not to use that functionality...

Nov 15, 2010 at 12:45 PM

Thanks for replies above.

I think the only thing is to replace CommentView.ascx and CommentView.ascx.cs to the control that doesn't use ajax.

Does anyone have such a CommentView.ascx and CommentView.ascx.cs?