An error occurred loading a configuration file:

Topics: ASP.NET 2.0
Nov 24, 2010 at 11:25 AM
Edited Nov 24, 2010 at 11:32 AM

Hello all,

I am using blogenine on of my site, it suddenly started giving this error on the right nav,

 

Widget Administration not found.

An error occurred loading a configuration file: Failed to start monitoring changes to '\web.config' because access is denied.

 

This is occuring on this line <blog:WidgetZone runat="server" ZoneName="be_WIDGET_ZONE" />

Please can someone advise what could be the cause for this error?

 

Thanks

John

Coordinator
Nov 24, 2010 at 5:37 PM

I've not seen that before, but I don't think it's a specific BlogEngine problem ... more of an ASP.NET problem.

See this Knowledge Base article with solutions for that error message.

I think that contains the answer, but if not, try this Google search.

Nov 25, 2010 at 12:22 PM

Hello 

Please check this blog.smithandgift.com

I am not sure whether its related to other .net issue?


Thanks

Coordinator
Nov 25, 2010 at 5:54 PM

Your blog is coming up correctly now... at least I don't see any error messages.

ASP.NET usually needs to monitor certain files.  One of them is the web.config file.  If it doesn't have sufficient permissions to access a file, I think that is when that error message appears.

There could be another cause for the error as well.  I don't think I've ever seen that error message in the BlogEngine Discussions before.  But it did show up in Google results, for other people using ASP.NET.  So for finding an answer (in case the problem persists), I think your best bet is to see what other people tried doing.