Documentation.chm is not working for me

Mar 11, 2008 at 10:12 PM
When I open Documentation.chm is get the table of contents but when I select any table item ther detail page on the right does not display. Instead I get an error message that says, "This program cannot display the webpage".

If I cannot get this to work, is there any online documentation for the application?

Thanks,
Bob
Mar 11, 2008 at 10:15 PM
I just found this. http://www.dotnetblogengine.net/wiki/MainPage.ashx

It would still be nice to have the working CHM file but I have what I need.

Thanks,
Bob
May 14, 2009 at 2:50 PM

I get the same problem (Contents, Index and Search work but no actual pages are displayed) with Documentation.CHM from 1.5 and 1.4.5.  This is with IE 7.0.

I also get an error with the above page (http://www.dotnetblogengine.net/wiki/MainPage.ashx), but have found this: http://blogengine.codeplex.com/Wiki/View.aspx?title=Documentation

 

May 14, 2009 at 2:59 PM

If you are running Windows Vista/7 you may need to unblock the CHM. To do this you need to right click on the file and select Properties from the context menu. In the General tab of the Properties dialog you should see an Unblock button just below the Advanced button.

May 14, 2009 at 3:12 PM

I am actually running XP SP2, but it is still the case that you need to unblock it.  However, I downloaded it to a FAT32 filesystem and there was no unblock option.  (I keep all downloads on a USB drive that I sometimes use with Windows 9X systems - hence it is FAT32.)

Anyway copying to NTFS allowed me to use the file.  Also downloading directly to NTFS allowed me to use the unblock option.

 

 

 

May 15, 2009 at 5:47 AM

CHM files internally are displaying HTML files.  That is why you see that message about not being able to view the webpage.

And yes, when you download it you should store it on a local drive and unblock it.  If you copy it to another machine it will still be flagged as blocked. :(  CHM files also can't run from network drives or removeable drives on most machines due to security restrictions.