This project is read-only.

Installation problem

Topics: ASP.NET 2.0, Business Logic Layer
Dec 15, 2010 at 8:22 PM
Edited Dec 15, 2010 at 10:10 PM

I am trying to set up my BE.N RC 2.0 site on GoDaddy, I've got IIS7 and ASP.NET 4.0 (Integrated). This works locally but not on the hosting site.

I've given write permissions on App_Data (and all children) and set the site folder as a virtual directory (I get a different error if I remove the virtual directory setting). The error suggests there's a problem with SendCommentMail.cs - but the actual file that throws the error changes (at least it has done for me if I visit the site 3 times I'll probably get at least 2 different files flagged.

I've double and triple checked the bin folder and BlogEngine.Core.dll is defintely in there. I've pulled down the latest version and compiled that (in release mode) to generate fresh copies of the dll and uploaded that but I'm still getting the error... what else can I try?


Server Error in '/sjmdev' Application.

Compilation Error

Description: An error occurred during the compilation of a resource required to service this request. Please review the following specific error details and modify your source code appropriately.

Compiler Error Message: CS0246: The type or namespace name 'BlogEngine' could not be found (are you missing a using directive or an assembly reference?)

Source Error:


Line 7:  using System.Web;
Line 8:
Line 9: using BlogEngine.Core;
Line 10: using BlogEngine.Core.Web.Controls;
Line 11:

Source File: d:\hosting\573115\html\sjmdev\App_Code\Extensions\SendCommentMail.cs    Line: 9

Show Detailed Compiler Output:
Show Complete Compilation Source:
Dec 15, 2010 at 8:45 PM

Sort of strange ... it seems like lately the solution for GoDaddy problems like this is to delete all of your files, and then re-upload them again!

At least right now, that is all that is coming to mind .......................

Dec 16, 2010 at 5:39 PM

Hi Ben,

Unfortunately that doesn't seem to work for me. I've deleted all the files, then re-uploaded them a few times (just to make sure). I also created a new folder, uploaded all the files and set it to be a virtual directory then pointed my domain to that folder - still no joy.

What else could it be?

Dec 19, 2010 at 9:03 AM

Hi Ben,

Has anything else come to mind?
I'm still unable to get my blog to run.

Dec 19, 2010 at 9:30 AM

A few things to try ....

Make sure none of the BE subdirectories are inadvertently marked as "application" or "virtual directories".  For example, make sure neither the App_Code directory or the App_Code\Extensions directory are marked as virtual directories.  Googling, I found this post where the person had done that (for a different app), and that caused the Type to not be recognized.  Sort of obscure, but you never know.

You could try recompliling the BE Core, and redeploying BlogEngine.Core.dll.  I've seen a couple of strange instances in the past where doing that solved a problem.

In your web.config file, check to see if you have a <namespaces> tag within <pages><controls>.  We have <namespaces> in the .NET 3.5 web.config files, but not in the .NET 4.0 web.config files.  Without it, BE is running for me on .NET 4.0, but it may help to include it.  It would be placed in the web.config file like:

<pages ...>
        <add namespace="BlogEngine.Core" />

Maybe you can also post your web.config file here.  There might be something that stands out.

Dec 19, 2010 at 11:12 AM
Edited Dec 19, 2010 at 11:21 AM

Hi Ben,

Thanks for the help, I really appreciate it

I've deployed the dll and the corresponding global.asax

In my GoDaddy  IIS management panel when I do not have the site folder set as Application Root I get "It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS." - which is fairly clear... With the option ticked the error becomes the "namespace name 'BlogEngine' could not be found".

The App Pool is set to ASP.NET 4.0 (Integrated), and I have recycled it to try to clear out any old cache.

Adding my config makes the post too long, so here's a link to it

Dec 21, 2010 at 8:00 PM
Edited Dec 21, 2010 at 10:48 PM

I got the following from GoDaddy support:
We understand that your .Net scripts within the hosting account for are erring. We have noted that our test file also erred until the /App_Code directory within you account was disabled. Once disabled, our test scripts worked normally. Unfortunately, we are do not offer scripting support, we will be unable to assist you with the troubleshooting of the contents within the /App_Code directory. If you are not the author of the content within the directory, you may want to contact the publisher of the application for further assistance.

To test this out I renamed the App_Code folder to see what happened; it moves the issue on to Global.asax (which must be the next place the dll is referenced), where it imports the namespace ( and removing that line just pushes the problem back further in the file as there are methods referencing that class - so that suggests that there's something going on in the App_Code folder that is causing the issue.

I tested RC 2.0 on both my GoDaddy hosting and an Amazon EC2 hosting a friend gave me access to, as well as my local IIS, surprisingly on the Amazon server I also got the namespace could not be found error. I compared my local IIS settings with those on the Amazon server and as far as I can tell they're identical. I'm not aware of any GAC changes locally - but I am surprised that I got the same error even though I could set up IIS as I thought it should be done.

I pulled this from the YSOD in case there's anything in there that helps to explain things (line breaks are mine, for readability)


C:\Windows\SysWOW64\inetsrv> "C:\Windows\Microsoft.NET\Framework\v4.0.30319\csc.exe" 
/R:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_GlobalResources.s9yoozlz.dll"
/out:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.dll"
/D:DEBUG /debug+ /optimize- /w:4 /nowarn:1659;1699;1701
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.64.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.45.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.16.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.8.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.11.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.20.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.49.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.34.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.67.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.9.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.19.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.42.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.10.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.23.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.1.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.36.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.24.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.69.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.51.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.35.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.61.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.13.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.7.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.41.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.53.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.5.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.39.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.27.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.48.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.55.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.22.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.32.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.12.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.25.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.40.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.2.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.59.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.50.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.38.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.26.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.68.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.60.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.15.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.3.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.31.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.6.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.56.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.29.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.57.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.62.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.0.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.14.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.43.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.30.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.70.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.66.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.28.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.47.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.65.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.44.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.63.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.54.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.4.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.52.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.33.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.21.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.18.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.58.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.46.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.37.cs"
"C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\sjm\60fdb596\cbaaabc0\App_Code.7q5ycb-n.17.cs"

Microsoft (R) Visual C# 2010 Compiler version 4.0.30319.1
Copyright (C) Microsoft Corporation. All rights reserved.


Does my web.config shed any light?

Dec 21, 2010 at 9:45 PM

Oops, I apologize ... I missed your update from a couple of days ago (Sunday) ... not sure how I missed it.  Glad you posted again.

At least you have sort of ruled out this being a GoDaddy specific problem since the same error is on EC2.  It's good we know this.

I'll look at the web.config file and details to see if I can see an issue, or possibly duplicate the error on my side.

Dec 21, 2010 at 9:58 PM
Edited Dec 21, 2010 at 10:13 PM

Go to content / IIS management in your GoDaddy's control panel and mark your site to be an "application root". There should be check box, I think under "advanced" or something like it. You should see a little blue globe icon added to your site folder in the list. Once you hit ok, GoDaddy will configure your site as application and all should work fine. Will take awhile - you'll get through usual "pending setup" drill.

Oh, and once you pass that and if you use XML provider - go to "file manager", check app_data folder and click "permissions" button on top of the list. Uncheck "inherit" and add write permissions so BE can write to app_data folder. Now should be all set.

Dec 21, 2010 at 10:34 PM

Maybe that will help him Ruslan.  This is sort of a long thread, but originally his site was configured as an application root.  I think he just temporarily took off the "application root" status to see what would happen.  Here's his web.config file.  He's using a DB for storage.

Simon:  I setup a new BE application under localhost on my computer.  IIS 7.5, .NET 4.0 integrated application pool with a SQL DB for Blog storage and also for Membership & Roles -- using the same SqlMembershipProvider and SqlRoleProvider you are using.  I also ran the Elmah setup script so I could use the same web.config file you are using -- i.e. no modifications.  The site is running for me without error.  I was hoping it would fail.

Also, did you recompile the BE core to produce a new BlogEngine.Core.dll file?  Do you have the BlogEngine.Core.dll file in your /bin directory where BE is?  Since you have BE installed in a sub-folder, you would want to make sure BlogEngine.Core.dll is in the /bin directory in that sub-folder -- not the /bin directory in the parent/root folder.

It sounds like you're using BE  I just compiled the BE core in BE  Here is a ZIP file of the BlogEngine.Core.dll file (along with PDF and XML) for BE that I compiled.  When you have a chance, download that ZIP file, unzip it, and use the BlogEngine.Core.dll file from there on your site ... just to see if there's any difference.

Dec 21, 2010 at 10:56 PM

Hi Ruslan,

The process is a little slow on GoDaddy; after setting anonymous access and application root on the folder it can take 5-10 min for the changes to happen - but I have gone through a few different configurations hoping to 'get lucky'.
I know the changes are happening because if I unset Application Root then refresh my site I get a different error that says about it being invalid to make changes at this level that have been made in the machine.config. Excuse the vagueness, I don't have the error in front of me at the moment.

I'm using SQL Server, but have given write permissions to the App_Data folder and reset permissions on all children too.

Unfortunately there still seems to be something amiss.


Dec 21, 2010 at 11:17 PM

Hi Ben,

Locally I have no problems with the site, configured either as a website or localhost/sjmdev - only when hosted, your local set up sounds identical to mine (I'm using Win7 64bit, don't know if that's causing an issue?)
I would quite like to be able to reproduce the error locally, it would give some better idea of what's happening and a place to start looking.

Tonight I pulled down, rebuilt the solution, used beyond compare to merge back my changes to the web.config (to enable debugging and the sql providers), then deleted everything from my hosted sub-folder (except the actual App_Data folder, though I removed all the contents). Then uploaded everything, checked the sub-folder was still configured as an application root (as Ruslan describes), confirmed the App_Data folder still had write permissions and tried the site - the compiler details listed above are from that test run.

On my hosting I have a folder for my blog (and other folders for other sites), the blog is in /sjm (GoDaddy manages to mangle my urls and so will have things like - where it's added the folder path to the url), that's the folder I'm using as the root of my site, so that's got /bin which has the .dlls in. I have also tried putting the bin at the very root of my hosting (in case there was some issue with IIS not being able to find the bin in the virtual directory. That also didn't solve it, and I have since deleted the folders.

Thanks for recompiling the dll - rules out the possibility that it's something about how I compile the code (thinking maybe 64bit could have been playing a part), I just tried that on my site, unfortunately it doesn't seem to have made a difference.

Dec 22, 2010 at 12:00 AM

Just got latest RC 2.0 running on GoDaddy with both XML and MsSql providers. Had to compile as .net 4.0 and used ASP.NET_4.0_Web.Config from setup folder for both. Nothing really need to be changed on BE side, it works fine as is. In GoDaddy, only had to set folder as app root and add write permissions, that's it. I'll do a post with step by step and screen shots, may be it will help better.

Dec 22, 2010 at 12:48 AM

I think Windows 7 64-bit should be fine -- that's what I'm running on my computer when I tested this earlier.  I'm almost certain all these webhosts are also running 64-bit editions of Windows Server 2008.

Ruslan, glad you were able to get it to work at GoDaddy (I don't have a GoDaddy account to test with).  In Simon's case, he's also not able to run his site at Amazon EC2.  So that let's us know it's probably not a GoDaddy issue.  At Amazon EC2 too, he receives the same error that "BlogEngine" is undefined.

Simon, I noticed you have a reference to flicker in your web.config file.  You might want to try removing that reference, and also remove any flicker DLLs from your BIN directory -- just as a way to try and reduce the amount of possible conflicts.  Same with Elmah ... I would try removing references to Elmah, including the Elmah DLL from the BIN directory.  For that matter, any other DLLs not related to BE, I would try removing from the /bin directory.  So you would end up with BlogEngine.Core.dll, AjaxMin.dll, and probably BlogML.dll too.

There's also a remote possibility that a conflict is occurring with the parent application.  You might want to consider adding the <location> tags shown in this post to the parent application's web.config file (not the BE web.config file).  You would want to wrap both the <system.web> section AND the <system.webServer> section in those <location> tags.  That prevents settings from propagating from the parent application to your BE application.

Dec 22, 2010 at 12:55 AM

In addition to the comments in my last post, if you're still getting this error after the above suggestions, I would try using the .NET 4.0 web.config file that comes with BE -- it's in the /setup folder.  This uses XML storage for everything, but that's fine.  It would be good to test if it works with that web.config file that comes with BE -- since you have a number of customizations to your web.config file.  If that web.config file that comes with BE works, then you can start moving back to your old web.config file -- adding one customization in at a time, until it breaks.

Dec 22, 2010 at 8:46 PM

Hi Ben and Ruslan.

Just had another go at getting this working. Downloaded the latest version of the site (, rebuilt the solution. Deleted everything from my hosting folder, then uploaded the new site, replaced the web.config with
the ASP.NET_4.0_Web.config, but otherwise left everything as is. Checked the folder /sjm was still set as a virtual directory and that /sjm/App_Data has write permissions. Then tried the site; I got the generic YSOD,
so merged some debugging back into that file and tried again and was a little dissapointed to see the familiar "namespace BlogEngine could not be found" error. I was hoping it would run the basic site and it was something
in my modifications that was causing the error - however I'm also a little pleased as it means it's not something I've done to BE.

I'd come to the conclusion that Elmah isn't worth adding, I'd disabled it and haven't re-enabled it, or uploaded the dll. I also left the flickr stuff out of the config and bin, I might add the flickr stuff back when the site is working.

Then I looked back at Ruslan's post about getting the RC working on GoDaddy by recompiling as net 4.0; could you explain how you did that? I'm also confused, because I can't seem to get the site working as you can.
With the 4.0 config in the root of the site (in Visual Studio), I tried setting the
Target Framework for ASP.NET 4.0 for both the website and BlogEngine.Core (27 errors all from the BE.Core project). With only the website set to 4.0 I get 1 error
"It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.    C:\Users\Simon\Desktop\blogengine_2272a642f238\BlogEngine\BlogEngine.NET\setup\Web.Config    9" - which is

<blogProvider defaultProvider="XmlBlogProvider">

Whereas with both projects set to ASP.NET 3.5 they both build fine.

Dec 22, 2010 at 10:39 PM

Check this post on building RC 2.0 with .NET 4.0, may be you missing a step or doing something different.

Dec 23, 2010 at 11:11 PM

Hi Ruslan,

Thanks for the details in the post; I was missing out the step about adding a reference to System.Web.ApplicationServices - which is why I got the errors when I tried to build it.

I'm still getting errors on GoDaddy with the site though. After compiling the site I uploaded it and ran it, I got the generic error page, so modified the config slightly
compilation debug = true, customErrors mode= off and

  <httpErrors errorMode="Detailed" />
    <asp scriptErrorSentToBrowser="true"/>

which means I can actually get to the details of the error, which is namespace cannot be found.

Again the site runs perfectly locally. I will test it on the Amazon EC2 server I've got access to as well, to see whether it's something about how my GoDaddy site is configured or if it's something else.

Jan 24, 2011 at 10:29 PM

I am still having issues with this - though Go Daddy are being pretty useless in helping me resolve them.

However I suspect that there may be something amiss with the dll's I generate for ASP.NET 4.0, because when I uploaded them to the Amazon server I again got the "Namespace or name 'BlogEngine' could not be found" error - If I restored the dlls that ship with the website (for 3.5) then the site works. I have followed the instructions in Ruslan's post so am not sure what the issue could be.


To illustrate my point about Go Daddy - they managed to set up a default instance of BE 2.0 on my account but it was displaying garbage html when logging in. They swapped in the ASP.NET 4.0 web.config file and I could get to the login page but on logging in then got garbage html. So they suggested I convert the app for 4.0, so I downloaded the existing dlls from the bin, uploaded the files I'd compiled and ran the site - ran into my old friend "Namespace or name 'BlogEngine' could not be found", so deleted my new dlls and uploaded the versions I'd downloaded... that did nothing to fix the issue - so I strongly suspect there's permissions going funny here but can't seem to get Go Daddy to see that.


Jan 24, 2011 at 10:48 PM

If you running into the wall, may be just email me your FTP info and I'll try to set it up. Kind of curious myself what could be an issue... You can change password later from Daddy's admin panel.