Can't view comments page on blog posts

Topics: ASP.NET 2.0
Jan 3, 2011 at 4:01 PM

I'm using BlogEngine.NET 2.0, and everytime I click on the comments page I get the following error:


This webpage is not available.

The webpage at might be temporarily down or it may have moved permanently to a new web address.

 More information on this error

Below is the original error message

Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.
Jan 3, 2011 at 8:54 PM

When you get this error message, it looks like there's a link shown in your message "More information on this error".  If you can click on that, it'll probably display more information which could be helpful in diagnosing the problem.  If you do have more error details and can paste them here, that would be great.

If you remove the #comment part at the end of the URL, it then works?

Are you using the Chrome browser?  What if you try other browsers ... same error?  I ask because when Googling for "ERR_CONTENT_DECODING_FAILED", the top hits seem to all be related to Chrome.  That error message and the error number "330" look like they are Chrome specific error messages.  This person said that he re-installed Chrome and this error disappeared.  Not sure if he was just lucky, or if the same thing might work for you too.  Might be worth giving it a shot.

Jan 3, 2011 at 9:25 PM

The link just shows/hides the error message that is posted below it in my original post

Below is the original error message

Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.

I get the same error without the #comment part in the url.

I am using chrome, but I did test it in IE8 as well, but the error it gives me is just "Internet Explorer Cannot Display the Webpage".

I also tried changing the option "Add date to post links" under the settings for the blog, with no change.

Is there perhaps a IIS configuration problem that could cause this behavior?

Jan 3, 2011 at 9:56 PM

Thanks for the info.

In your web.config file, there is a custom errors tag.  I would change the "mode" it so it is "Off":

<customErrors mode="Off" defaultRedirect="~/error.aspx" redirectMode="ResponseRewrite">

After doing this, if you still get the error message, there's a global.asax file that contains an "Application_Error" handler.  I would try temporarily deleting that whole Application_Error handler from the global.asax file.  And then try pulling up the same URL again.  The Application_Error handler basically looks like:

void Application_Error(object sender, EventArgs e)
	HttpContext context = ((HttpApplication)sender).Context;
	..............  CONTENT SNIPPED  ..............
	// Custom errors section defined in the Web.config, will rewrite (not redirect)
	// this 500 error request to error.aspx.

Hopefully you'll get an actual error message, or some yellow screen of death, rather than what you're seeing now.

Jan 3, 2011 at 10:04 PM


Changing customErrors to off solved the problem, and I can now view both the post page and the comments pages just fine.


Thank you for the help!

Jan 3, 2011 at 10:32 PM

That's good.  You could and probably should change it back to RemoteOnly which is better since it won't reveal error details to people if an error later occurs.

When you make a change to the web.config file, it restarts the blog.  My guess is that you just needed to restart the blog for something to clear out.  You can try changing it back to RemoteOnly, and if you start receiving errors again (which I don't think will happen), you could then go back to "Off".