Culture name 'xxx' is not supported

Topics: ASP.NET 2.0
Jan 13, 2011 at 1:47 PM

Hello,

 installed blogengine 2.0. Deleted the previus version 1.5. Updated database with scripts. Blog works until I change the config to the one from MSSQL.

Then I get Culture name error.

If I go direct to admin pages - they work, I can even change the existing posts or write new ones, but when I want to see it (preview of frontend), the error is the same.

Any help fixing the problem would be wery nice.

Thanks!

 

Error details:

 

Culture name 'si-sl' is not supported.
Parameter name: name

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentException: Culture name 'si-sl' is not supported.
Parameter name: name

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace:

[ArgumentException: Culture name 'si-sl' is not supported.
Parameter name: name]
   System.Globalization.CultureTableRecord..ctor(String cultureName, Boolean useUserOverride) +7484249
   System.Globalization.CultureTableRecord.GetCultureTableRecord(String name, Boolean useUserOverride) +213
   System.Globalization.CultureInfo..ctor(String name, Boolean useUserOverride) +45
   BlogEngine.Core.Utils.AddJavaScriptResourcesToPage(Page page) in Utils.cs:494
   BlogEngine.Core.Web.Controls.BlogBasePage.OnLoad(EventArgs e) in BlogBasePage.cs:361
   System.Web.UI.Control.LoadRecursive() +50
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +627


Coordinator
Jan 14, 2011 at 3:10 AM

It sounds like the control panel pages work.  I would go to the Settings tab ... the Basics subtab where "Choose language" dropdown list is, make sure that "Auto" is selected, and click "Save".

I'm not sure if this will help ... but if for some reason a culture of "si-sl" is saved in the DB (the be_Settings table), this would set it to "Auto" which should eliminate the error.

Jan 14, 2011 at 7:49 AM
BenAmada wrote:

It sounds like the control panel pages work.  I would go to the Settings tab ... the Basics subtab where "Choose language" dropdown list is, make sure that "Auto" is selected, and click "Save".

I'm not sure if this will help ... but if for some reason a culture of "si-sl" is saved in the DB (the be_Settings table), this would set it to "Auto" which should eliminate the error.

Thanks for help, it didn't work, but the direction was ok. The probelm was the language settings of RSS feed. Changed that - works like charm.

TNX agn.