nothing but "special characters" when browsing

Topics: ASP.NET 2.0
Jan 17, 2011 at 6:28 PM
Here is what I get when I deploy to a shared hosting site ... this is default.aspx ... but browsing to most other pages come up with something similar.
Anyone else run into this issue ??  ... I simply ftp-ed an app that runs fine on my local machine.
Steve
`I%&/m{JJt`$ؐ@iG#)*eVe]f@흼{{;N'?\fdlJɞ!?~|?"Ey')=y6hz<=~|W>Z5uA:f/>y(Gd^ϲe!zѲY)5GA8VeU?/I=YdEnգt/q
IUn
ۻ/NoN| &}
0euU?_OYT˦*s30_/	ۼV@ʄJTHY>-tY-e^7Uŋ:[`+'UVG]ݻUeFv{^/gy]{#.usuS]Uq?'賏Ed Bw^5[*-wVe1eǏuzUg;;{lW)Jr.A5;J]-ømlq]d(vN(<_z:[6ۯuգ_M^idԓiLb%<xfnLq5%v
Simnh&obyДF@/
@6+&~5A-,+BU9wE5}5$"waS(WWb'uuEChz\YKtN>ҌS#P1}S97H"Fʧy1!..ie7	+FIDYKR%Ly^i]kROKE='i</.TXE)oBP4SΊ:U}m&L7'
@DcBaγ<-FQ[T\ڶ.&ւx-S̓G+?~Nt
on;M	ۣno%0ESaL iŘh>7dMA:Ĺº:|cy|%n i|!"QyAm,ZY
n`fKHȆ(gcOq~wBY~U.<cxC{b<CWĻ}}eyљ#m </;7y 'Yw
Jan 17, 2011 at 6:33 PM

Have you deployed on .NET Framework 4.0?

Jan 17, 2011 at 7:19 PM

 

thanks for the prompt reply .... this has been a nightmare ....

Well ...  it's asp.net 2.0 ....  assume that it is 3.5 ... will check with "DailyRazor" support ...

but at this point ... I'll be happy to just get 1.4.5 installed ... when I run the installer from Plesk I get

Warning: Web application installation failed: websrvmng failed: Filename: \\?\C:\inetpub\vhosts\technology-advisor.com\httpdocs\Advisory\web.config
Error: The configuration section 'system.webServer/defaultDocument/files' cannot be read because it is missing a section declaration
In module
Exception type: System.Runtime.InteropServices.COMException
at Microsoft.Web.Administration.Interop.AppHostWritableAdminManager.GetAdminSection(String bstrSectionName, String bstrSectionPath)
at Microsoft.Web.Administration.Configuration.GetSectionInternal(ConfigurationSection section, String sectionPath, String locationPath)
at Microsoft.Web.Administration.Configuration.GetSection(String sectionPath, String locationPath)
at CInternalUtils.GetGlobalSection(String sPath, String sLocation)
at CInternalUtils.GetGlobalSection(Char* sPath, Char* sLocation)
at CIIS7SiteBase.SetDefaultDocuments(CIIS7SiteBase* , Char* virtdir, Char* defaultDocs)

Jan 17, 2011 at 7:29 PM

I'm under impression you're trying to install BlogEngine on IIS7. If it is the case, If it's the case, you need to select the right application pool. I suggest you configure BE to use ASP.NET cClassic app pool.

You might also need to modify your web.config.

Are you using Xml or Db Blog provider?

 

Jan 17, 2011 at 7:36 PM

here's the response re: .Net version ... make sense ??  seems a bit evasive ..

Dear Customer,

.NET Framework 3.5 is addon to .NET 2.0 and .NET 3.0, but .NET 3.0 is not supported by Plesk interface, however addon itself is installed and all new features are available using 2.0 version at Plesk.


Let us know if there any questions we can help you with, or confirm that we may close this ticket.
 

Jan 17, 2011 at 7:43 PM

checking on the 1.4.5 web.config issue ... not sure what the 'system.webServer/defaultDocument/files' element needs to look like

the plesk install for 1.4.5 did not ask for any odbc info ... so I assume it is XML as is the 2.0 version that I'm trying to deploy via FTP.

thanks again ..

Steve

 

Jan 17, 2011 at 7:50 PM

 

Shared application pool is running Integrated mode.
Jan 17, 2011 at 7:53 PM

Switching to classic mode should fix the problem with special characters

Jan 17, 2011 at 8:15 PM

not possible ...

 

"Unfortunately, it is not possible to change application pool mode on a shared hosting server, that is why you should refer to official developers documentation to find if there any specific settings you should configure (at web.config) to host it on IIS7."
 

can I tweak web config or put some dll's in the bin directory to fix it ???

.... I'm shopping for a good virtual hosting platform that I can RDP into ... Have one now, but the domain I want to blog on is regisistered on this shared site ....

any outstanding hosting vendors on your radar ???

Checking out the web config issue for 1.4.5 now ... just want to publish something to my domain asap ... and since I'm a .net developer ... want to use BlogEngine

Jan 17, 2011 at 9:35 PM

If your BE is running in ASP.NEt 4.0 application pool you need to:

- use ASP.NET_4_0_Web.config as your web.config

- remove all "rights" attributes from web.sitemap

for example if you have

  <siteMapNode url="~/admin/Dashboard.aspx" title="dashboard" description="" rights="AccessAdminPages" />

change it to

  <siteMapNode url="~/admin/Dashboard.aspx" title="dashboard" description=""/>

 

Coordinator
Jan 18, 2011 at 3:21 AM

I was just able to "reproduce" this exact error by corrupting the theme. I took out server-side element from theme's master page, code behind couldn't find it and ran into runtime error. Because I wasn't building it in VS, I did not catch this error and website showed me screen with those special characters.

What you can try is switch to different theme (admin/pages/settings.aspx) and see if that will work. If it will, you'll need to find and fix error in your theme.

Another possibility could be that you have corrupted data file. Then you can rename app_data to something like app_data_backup and throw in standard clean app_data folder, then hunt down corrupted data file, either in app_data/posts or app_data/pages.

If you using database, same thing just instead for backing up XML files you'd need to backup data, reload defaults etc.

Now that we can reproduce this error, we should be able to figure out how to catch this corrupted output and display meaningful error message instead.

Jan 18, 2011 at 4:10 AM
neuromancer wrote:

If your BE is running in ASP.NEt 4.0 application pool you need to:

- use ASP.NET_4_0_Web.config as your web.config

- remove all "rights" attributes from web.sitemap

for example if you have

  <siteMapNode url="~/admin/Dashboard.aspx" title="dashboard" description="" rights="AccessAdminPages" />

change it to

  <siteMapNode url="~/admin/Dashboard.aspx" title="dashboard" description=""/>

 

 nope asp.net 2.0 .Net 3.5 .... described thusly:

Dear Customer,

.NET Framework 3.5 is addon to .NET 2.0 and .NET 3.0, but .NET 3.0 is not supported by Plesk interface, however addon itself is installed and all new features are available using 2.0 version at Plesk.

and this hosting provider is fingerpointing back to Plesk .... do you developers have a pipeline (someone to talk to) at Plesk ??.... seems a shame that BlogEngine can be distirbuted bundled with Plesk without any FAQs or How To's ...

 

Jan 18, 2011 at 4:23 AM

this is the best guidance that I got from the hosting provider's support team .... ( going to try it now) ....

This is their guidance on correcting the:

Warning: Web application installation failed: websrvmng failed: Filename: \\?\C:\inetpub\vhosts\technology-advisor.com\httpdocs\Advisory\web.config
Error: The configuration section 'system.webServer/defaultDocument/files' cannot be read because it is missing a section declaration
In module
Exception type: System.Runtime.InteropServices.COMException

"install failed" message that appears after the Plex install from their Admin/Apps page

The suggestion:

 Please try to use site preview URL to see an actual server error message, either try to disable custom error documents at your web.config:

http://208.43.246.2/$sitepreview/mydomain.com/advisory
and the results of using $sitepeview

(Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)

  • Migrate the configuration to the system.webServer/handlers section. You can do so manually or by using AppCmd from the command line - for example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/". Using appcmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.
  • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
  • Alternatively, switch the application to a Classic mode application pool - for example, appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool". Only do this if you are unable to migrate your application.

(Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)

Jan 18, 2011 at 9:53 AM
tsaltd wrote:

this is the best guidance that I got from the hosting provider's support team .... ( going to try it now) ....

(Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)

  • Migrate the configuration to the system.webServer/handlers section. You can do so manually or by using AppCmd from the command line - for example, %SystemRoot%\system32\inetsrv\appcmd migrate config "Default Web Site/". Using appcmd to migrate your application will enable it to work in Integrated mode, and continue to work in Classic mode and on previous versions of IIS.
  • If you are certain that it is OK to ignore this error, it can be disabled by setting system.webServer/validation@validateIntegratedModeConfiguration to false.
  • Alternatively, switch the application to a Classic mode application pool - for example, appcmd set app "Default Web Site/" /applicationPool:"Classic .NET AppPool". Only do this if you are unable to migrate your application.

(Set "Default Web Site" and "Classic .NET AppPool" to your application path and application pool name)

How unfortunate your provider doesn't allow you to use Classic AppPool.      

You could try to add:

 <defaultDocument><files><add value="default.aspx" /></files></defaultDocument>

to <configuration><system.webServer> section (if you don't <system.webServer> create one)

 

Jan 18, 2011 at 2:07 PM

Have your hosting provider check the permissions of the ROOT folder where BE is installed. I had this same problem when I updated to BE2.0 only to discover that the permissions had changed. I had to re-add IIS_IUSRS to the root with READ & EXECUTE, LIST FOLDER CONTENTS, and READ permissions. They may need to to check which Identity the App Pool is running as also. 

Jan 19, 2011 at 7:27 PM

working on all the recommended fixes ...

could this be an issue:

Maximum size of the ASP buffer (KB) *    KB    Defined by parent directory (4096 KB)
Maximum size of entity body of an ASP request (KB) *    KB    Defined by parent directory (196 KB)

Jan 20, 2011 at 2:03 AM

 lots of tweaking of web.config to straighten out th e Ajax / Linq, etc references ... the 3.5 dlls were on the hosting service's machine, but references needed to be added to config .

.... and the override fix setting system.webServer/validation@validateIntegratedModeConfiguration to false ... a critical declaration

2.0 is working now .... 

thanks for the support !!

Steve