Video is not playing

Topics: ASP.NET 2.0, Controls
Jan 28, 2011 at 5:16 AM

I have uploaded an video mpeg4 file for an post. After successful upload, in the post the video is not playing

may I know what would be the problem...

Coordinator
Jan 28, 2011 at 5:38 AM

I would check and make sure the video you uploaded is physically in the /media folder.

Second, make sure the [video] tag exists in the post.  It'll look like:
[video src="videoname.mpeg4"]

What is the extension of the video file, btw?  Is it .mpeg4 or .mp4?

Try navigating directly to the video in your browser.  The URL will look something like:
www.example.com/media/videoname.mp4

If the video starts playing or you get a Download/Save As dialog window, that is good.  But if you get a 404, Page Not Found error, and the file does exist in the /media folder, this probably means the MIME type for the extension is not setup on the server.  If you're using IIS7, you can add the MIME type yourself in your web.config file (the one below is a MIME type for the .MP4 extension).

<system.webServer>
	<staticContent>
		<mimeMap fileExtension=".mp4" mimeType="video/mp4" />
	</staticContent>
</system.webServer>

If IIS6, the MIME type has to be configured directly in IIS.

Feb 4, 2011 at 8:26 AM
Edited Feb 4, 2011 at 8:27 AM

Thanks BenAmada.

This was awesome. You made my life easy. It worked :)

Mar 7, 2011 at 4:35 PM

Hi,

I am experiencing the same issue, except with all video files and your above solution doesn't work for me unfortuantely,

Checklist:

I have tried uploading the following 2 video files when creating a post i.e. WMV and MP4

- Both WMV & MP4 both a registered MIME type on my IIS 6 server

- I have even registered them via the mimeMap within the web.config file

- Files present in media folder, therefore uploading is fine

- I can navigate to the file via the browser and it plays fine

Any ideas?

 

M

Mar 8, 2011 at 7:09 AM

seeing the same issue.

Tried with mp4 and flv. The post displays the tag in text rather than replacing it with the video on display. The files are there and browsable. Does the server need to be able to play the files? I have no FlashPlayer and no MP4 codecs on my server.

 

Mike

Mar 8, 2011 at 1:00 PM

Does anyone have a solution to this issue.

File uploads but all I see in the post is a black box, which is the place holder for the video, but the video doesn't play. Markup looks fine and the original blogenging post which references the remote media folder and video plays fine!

[video src="http://dotnetblogengine.net/media/blogengine-welcome.mp4" type="video/mp4" width="600" height="480"]

Thanks

Mar 8, 2011 at 2:48 PM

Where is your site? I'd like to see what's happening but not sure if I can offer much help.

Mar 8, 2011 at 3:29 PM

Hi,

It turns out that MP4 was not a registered mime-type in iis 6, although I was sure it was, so I added it and bingo MP4 video's embedded within posts now play.

However, WMV's still don't work despite definitely being a registered mime-type on my server. And for arguments sake I removed it, re-added it (video/x-ms-wmv), restarted IIS , but to no avail.

Scratching my head here......

Mar 9, 2011 at 9:40 AM

For anyone experiencing the same issue I managed to solve it.

Solution:

Blogengine uses silverlight to render WMV files within posts. There is a file called silverlightmediaelement.xap in the scripts > mediaelement folder which is a control required for this to function. .xap was a missing mime-type extension in IIS, adding it solved the problem!

.XAP

application/x-silverlight-app.

Mar 9, 2011 at 3:05 PM

my site is www.husky.at I will put a post with the video up in a second again.

thanks for checking

 

Mar 10, 2011 at 5:49 AM

Fixed the Flash playing issue at least.

My Filenames had [] in them that seems to throw the parser off as they also are the tag delimiters we key of. Dooh

Renamed the files and voila

Mike

Apr 9, 2013 at 8:51 PM
Hi , I am new using BlogEngine,

I have a question I do all that you said in the post, but I can make to do work the video, I dont see anything, the video is write correct in the entry, but when I see in the page, I dont see anything neither the black box or a link.

Can you give me some recomendation.
Nov 13, 2013 at 8:23 AM
Hi Mhenaosakr,

Could you able to solve this issue? . Because I do face the same problem. Thanks.