How to Add a Widget

Topics: Controls
Feb 2, 2011 at 7:57 PM
Edited Feb 2, 2011 at 8:05 PM

Hi all,

How can we do when a Widget  dont appears on Extensions List ?

I want to install Feedjit Widget ( ) but after:

  • Download widget
  • Unzip and copy files to ~/widgets/ folder
  • Login to site

    I can't Find the add widget dropdown for add the Feedjit widget

    Some Details: BE 2.0 with i3Theme and running on XML

    any idea?

    Thanks :-) 


  • Feb 2, 2011 at 9:38 PM

    A widget is not an extension, so it wouldn't show up there.  Instead, while being logged in, visit your main page and there's a drop-down box that says "Administration" in it, your new widget should be listed there, select it and click Add.  Then you can move it where you like, and also edit the settings by clicking the Edit button.

    Feb 2, 2011 at 10:33 PM

    Very Nice, you right. I have found. I have needeed to change the default theme for "Standard" to the the Dop-down Box appears and it works.

    Now i have another problem, that is when i click Add nothing appens.

    Im going to continue searching the issue for the problem.

    Many Thanks johnny

    Feb 3, 2011 at 4:23 PM

    Well, without being able to really inspect what's going on - my *guess* is that the widget was written prior to BE 2.0, and a lot of add-on widgets won't work. See this page: for more info.  It's a simple fix, as all you have to do is edit the widget.aspx.cs and add a Using statement.  It's worth a shot.

    I'm guessing you don't see the error described in the above link because you're not actually trying to view the widget, just load it; so there's an error happening, but it's "under the hood" so to speak.

    Good luck!

    Feb 3, 2011 at 4:58 PM
    Edited Feb 3, 2011 at 5:05 PM

    Wow ! You Fix It !

    Thanks jonnhy, I have add:

    using App_Code.Controls;
    using BlogEngine.Core.Web.Extensions;

    To edit.ascx.cs and widget.ascx.cs files and it works.

    Thanks Again


    Feb 3, 2011 at 5:23 PM

    Glad it worked!  I had a feeling that's what it was since I literally *just finished* going through that same thing with the Flash Tag Cloud widget not an hour before I saw your reply this morning. :)