Culture name 'zh-TW\_vti_cnf' is not supported......

Topics: ASP.NET 2.0
Mar 21, 2008 at 1:18 PM
I get the following error when I click on the "Settings" in under administration.
I can't find any reference in the code to 'zh-TW' but i suspect that the problem has something to do with: <globalization requestEncoding="utf-8" responseEncoding="utf-8" culture="auto" uiCulture="auto" /> in the web.config file.

Does anyone know a fix to the error shown below????:

Culture name 'zh-TW\vticnf' is not supported.
Parameter name: name
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.ArgumentException: Culture name 'zh-TW\vticnf' is not supported.
Parameter name: name

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:


[ArgumentException: Culture name 'zh-TW\_vti_cnf' is not supported.
Parameter name: name]
System.Globalization.CultureInfo.GetCultureInfo(String name) +2820252
System.Globalization.CultureInfo.GetCultureInfoByIetfLanguageTag(String name) +78
adminPagesconfiguration.BindCultures() +156
adminPagesconfiguration.Page_Load(Object sender, EventArgs e) +37
System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +15
System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +33
System.Web.UI.Control.OnLoad(EventArgs e) +99
System.Web.UI.Control.LoadRecursive() +47
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1436


Mar 21, 2008 at 6:16 PM
Found the sollution:

If the server has installed frontpage extension then this should be removed or the "vticnf" folder needs to be removed within the \bin\language-folder fx. /bin/uk/.

Jun 7, 2008 at 2:57 PM


Ole wrote:
Found the sollution:

If the server has installed frontpage extension then this should be removed or the "vticnf" folder needs to be removed within the \bin\language-folder fx. /bin/uk/.

or.... :) just add the following code.  Seemed to work for me.
file : admin/Pages/Settings.aspx.cs: Line 245

 

if ((!String.IsNullOrEmpty(resourceDir)) && (resourceDir.Contains("_vti_cnf") == false))

 

This excludes the dumb FP extension stuff.


Aug 15, 2008 at 8:27 PM
With BlogEngine 1.4.5, the line number has changed to 254.
Apr 18, 2009 at 5:05 AM
Thanks KoboldChieftain, that worked right off the bat :-)
May 15, 2009 at 1:27 PM

The correct line number is 279 in 1.5.

Mar 5, 2010 at 4:50 AM

The correct line number is 269 in 1.6