Setting up BlogEngine.net with Abyss Web Server

Topics: ASP.NET 2.0, Business Logic Layer, Controls, Themes
Mar 22, 2008 at 3:54 AM
Server Error in '/BlogEngine' Application.
Security Exception
Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.
System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) +2668969
System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) +717
Aprelium.FCGIDotNet20.Connection.GetVariable(String name) +0
Aprelium.FCGIDotNet20.Request.GetServerVariable(String name) +11
System.Web.HttpRequest.FillInServerVariablesCollection() +133
System.Web.HttpServerVarsCollection.Populate() +29
System.Web.HttpServerVarsCollection.Get(String name) +36
System.Collections.Specialized.NameValueCollection.get_Item(String name) +4
System.Web.HttpRequest.get_Item(String key) +152
BlogEngine.Core.Web.HttpModules.CompressionModule.context_PostReleaseRequestState(Object sender, EventArgs e) +119
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +138
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +65
Mar 26, 2008 at 6:42 PM
Edited Mar 26, 2008 at 6:44 PM
Hello Eastons,

That issue has already been fixed, actually its not an issue but you just need to remove an entry on your web.config file. refer to this link from the issue tracker that i have raised before, my site is now up and running on top of Aprelium Abyss web server. Cheers!

http://www.codeplex.com/blogengine/WorkItem/View.aspx?WorkItemId=5803